Docker Run command not running properly

What am I doing wrong with my Docker Run Command?

docker run -d --restart unless-stopped -p 28967:28967 \
-e WALLET=“0xMyaddress”
-e EMAIL=“user@mydomain.com"
-e ADDRESS=“myddns.domainname.com:28967"
-e BANDWIDTH=“40TB"
-e STORAGE=“23TB"
–mount type=bind,source="/Users/informationsystems/Library/Application Support/Storj/Identity/storagenode",destination=/app/identity
–mount type=bind,source=“/Volumes/Storj/",destination=/app/config
–name storagenode storjlabs/storagenode:alpha

When I put this into my terminal window I get:

instead of the command completing properly. The “>” signs start after the first line of the command.

I have to Ctrl-C the command to get out of the ‘>’

> means that something did not close in the script (missing trailng ", \, or )

docker run -d --restart unless-stopped -p 28967:28967 \
-e WALLET=“0xMyaddress” \
-e EMAIL=“user@mydomain.com" \
-e ADDRESS=“myddns.domainname.com:28967" \
-e BANDWIDTH=“40TB" \
-e STORAGE=“23TB" \
–mount type=bind,source="/Users/informationsystems/Library/Application Support/Storj/Identity/storagenode",target=/app/identity \
–mount type=bind,source=“/Volumes/Storj/",target=/app/config \
–name storagenode storjlabs/storagenode:alpha \

A couple of your quote characters, the " characters, are curly. Meaning “. The ones right behind your TB characters are the correct ones: " . Do a copy and past of these.

If using TextEdit on macOS, in preferences you can switch off the use of curly quotes.

1 Like

It ended up being a combination of both suggestions. There was an extra ’ / ’ in one of my paths which got me a real error message instead of the unclosed script and then the curly quotes vs. regular ones was what actually had the command complete without errors. Thanks for the help!

1 Like