Does the Filezilla integration not work anymore?

Hi all,

I use storj as an offsite backup of a home server. I started using the cli but I very recently stumbled across the storj drop down option in filezilla. I love filezilla because I can use the same gui across multiple OS.

I tried to set this up and I can’t get it to work. I’ve tried both current Filezilla (3.62.0), which leads to an access grant format error.


I also tried using the legacy api key option and got a different error: failed to parse API key: uplink: metainfo error: rpc: tls: first record does not look like a TLS handshake.

I also tried an old version prior to the update to the access grant login option (3.46) and got a third error. Request failed with status code 0

In all versions, I used multiple urls (, us1.storj, tardigrade…). None worked. I’ve also tried generating multiple access grants but that isn’t the issue. I haven’t found many posts of people having these issues or solutions for these specific error messages. I have seen the post about Filezilla using old Storj libraries (Can't login with FileZilla - #12 by heunland) but this was a while ago.

I can upload more screenshots of the errors if needed (limited due to new user). Any advice would be appreciated. I like storj as a cloud option and filezilla would make utilizing it as a backup most convenient across my devices. Thanks for any help.

Did you follow the steps shown on below page ?

1 Like

Hello @andrewsb8,
Welcome to the forum!

It’s still working, but you need to use an access grant method. Perhaps the API key + password + satellite address authentication method doesn’t work anymore, because the Filezilla team is procrastinating updates of underlaying uplink.
However, it’s still work for me, but this Filezilla installation have an old API-key+password+satellite address method, the new fresh installation doesn’t have it.
Just checked - updated my Windows Filezilla installation and configured using the access grant, it’s connected and able to upload and download files as usual.
The only caveat - that you may not see the size of the objects, uploaded not via Filezilla (because of a very old underlaying uplink).

Thanks for the quick responses. Yes I was following the guide.

I figured out the issue. I had filezilla set up to not remember passwords. When I let it save the password the connection works with the access grant. It might be useful to add this as a quick comment in the guide.