[Duplicati] not possible connecting to a bucket using API Key (CLI) to perform a backup

I downloaded the canary version of Duplicati as indicated in your documentation Backup With Duplicati | Storj Docs, the version I installed is v2.0.6.104-2.0. 6.104_canary_2022-06-15 (but the problem also occurs with previous versions), after configuring access to the bucket via the “API key” authentication method, I perform the connection test but immediately appears the error window you see in screenshot, I tried to manually enter satellite’s address using the one that was provided when I created access via CLI but the problem is’nt solved, for storage type I tried Tardigrade (which is deprecated) and "Storj DCS "but the error always appears, I have disabled firewall and any other software that may be preventing the connection.


I have the same problem.

Can you send a screenshot of what your configuration looks like? The fields in the “Backup destination” form would be most helpful.

my configuration is the same described here Backup With Duplicati | Storj Docs
as I wrote in the first post I also used the storage type “Tardigrade”

But what did you use as the satellite address?

I think you might need to specify it as {SatelliteNodeID}@{IP-Or-Hostname}:{Port} in this context (although I’m not sure where to find the integration source at the moment). For example,


default one, in my case: eu1.storj.io:7777 i have tried also the address that was provided when I created access via CLI wich one end with @eu1.storj.io:7777, when i click “test connection” appear the error’s screen

Sounds like I need to look at the duplicati source. I’ll get back to you.

@TopperDEL It looks like you might be able to help with this. I’ve been able to reproduce the error described by the above users. Essentially, it looks like when you choose an existing satellite, the Node ID part of the address is not included (leading to an error from the uplink library), and when you choose a custom satellite instead, it does not actually get sent to the server.

Here’s the content of the request that gets sent when I click “Test connection”:;


Note that storj-satellite here appears to be empty.

Any ideas what we should do?

If you do not specify your own satellite and just choose it from the list, this method is working, just checked.
The bucket name should be low case using alphanumeric and dashes.

Used docker version duplicati/duplicati,

Thanks everyone for help, but the version I used is from 2022 so we are forced downgrade to a version released over a year ago? If so, it would be necessary update the documentation relating to backups with Duplicati or can storj’s developers fix this issue?

Seems bug in Duplicati, it’s unlikely that our developers can fix it, but we will try to reach out the Duplicati team to fix the issue.

With the new version you can also use an access grant authentication method. You can create an access grant via GUI or via CLI and use this access grant with method Access grant in the Duplicati configuration.


i have created a new access grant and using method Acces grant in Duplicati now all seemes to be work fine even with latest canary version v2.0.6.104-2.0. 6.104_canary_2022-06-15.
Thank you!