Error on first-time setup: Error: open /app/config/config.yaml3188767146: read-only file system

Hello, I’ve been running storj nodes for a few years now, and because of a new hardware switch, I decided to start from scratch. However, when I attempt to run the first script, I stumble across this error:

Running ./storagenode setup  --config-dir config --identity-dir identity --metrics.interval=30m --version.server-address= --console.address=:14002 --storage.allocated-disk-space=2.0TB
2023-03-30T17:11:01.950Z        INFO    Anonymized tracing enabled      {"Process": "storagenode"}
Error: open /app/config/config.yaml110332788: read-only file system

I went to check for the /app directory, but that directory does not even exist. Below is my first-time setup script:

sudo docker run --rm -e SETUP="true"     --user $(id -u):$(id -g)     --mount type=bind,source="/home/server/.local/share/storj/identity/storagenode",destination=/app/identity     --mount type=bind,source="/srv",destination=/app/config     --name storagenode storjlabs/storagenode:latest

Is it because it’s trying create a directory in the / directory? I’ve been using storj on windows and just decided to switch to linux. Any help would be appreciated!

Hello @nodefinder0,
Welcome to the forum!

You might migrate your node: How do I migrate my node to a new device? - Storj Docs, but well

Sounds like your filesystem is read-only (you may Google how to fix it) or you have a wrong permissions there.

You should either to configure your docker to run without sudo or remove --user $(id -u):$(id -g) option from your docker run command.

Problem solved! I had to remount the filesystem via /mnt/ through a static mount.

1 Like