Error: open /app/config/config.yaml1654586245: permission denied

Hi all,

I have completed the setup up until running the following command :
docker run --rm -e SETUP=“true” --mount type=bind,source="",destination=/app/identity --mount type=bind,source="",destination=/app/config --name storagenode storjlabs/storagenode:latest

Although upon execution, I get a permission denied status message. Can anyone assist please?

Hi :slight_smile:

You need to specify where your signed identity files are, and where you want to store the node data in your docker run command - yours is blank - I’ve marked them for you below with xx

--mount type=bind,source="**xx**",destination=/app/identity --mount type=bind,source="**xx**",destination=/app/config

This guide tells you what each parameter is Storage Node - Node Operator

Hi,

Thanks for the reply.

So I have specified the source and destination file and/or folder locations but still get the error. Please help.

So this is the full command :
docker run --rm -e SETUP=“true” --mount type=bind,source=C:\Users\***\AppData\Roaming\Storj\Identity\storagenode,destination=/app/identity --mount type=bind,source=C:\,destination=/app/config --name storagenode storjlabs/storagenode:latest

And get this error :
Error: open /app/config/config.yaml3848382200: permission denied

No :confused:

That won’t work on Windows, and you don’t want the Storagenode to be on the root of the C:

Please create a directory on the C: something like StorjNode01 - C:\StorjNode01

And pass that directory instead…

Big thanks!

That worked.

Although now when I try to run the following command :
docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967/tcp -p 28967:28967/udp -p 127.0.0.1:14002:14002 -e WALLET=“0xMYWALLET_ADDRESS” -e EMAIL=“MY_EMAIL_ADDRESS” -e ADDRESS=“MY_PUBLIC_IP_ADDRESS:28967” -e STORAGE=“1TB” --mount type=bind,source=C:\Users\***\AppData\Roaming\Storj\Identity\storagenode,destination=/app/identity --mount type=bind,source=C:\StorjNode01,destination=/app/config --name storagenode storjlabs/storagenode:latest

I receive an access denied status message. Please help.

Dont run docker on windows that is a bad idea…

It works. I have migrated my docker to wsl2 and on version docker-desktop 4.2.0 it’s pretty stable.

1 Like

It’s running, but still showing offline. I have applied all port forwarding settings.

image

In addition please provide the last 10 lines from your logs: How do I check my logs? - Node Operator