Error: open /app/config/config.yaml3725284116: permission denied

I keep getting an error when i try to do the command :

docker run --rm -e SETUP=“true”
–user $(id -u):$(id -g)
–mount type=bind,source=“”,destination=/app/identity
–mount type=bind,source=“”,destination=/app/config
–name storagenode storjlabs/storagenode:latest

I have changed the info needed in the but when i run this here is what i get :

Running ./storagenode setup --config-dir config --identity-dir identity --metrics.interval=30m --version.server-address= --console.address=:14002 --storage.allocated-disk-space=2.0TB
2023-01-29T23:09:36.690Z INFO Anonymized tracing enabled {“Process”: “storagenode”}
Error: open /app/config/config.yaml3725284116: permission denied

I am running the command as sudo as well with same result . Also have a concern that it says it is only allowing 2TB when I want to use 9TB can someone PLEASE help me. Thank you

Hello Reverend D,

So, is this the first time you’ve run the setup? Seems like you already did, so the SETUP=“True” doesn’t need to be run again.

Also, have you set permissons on the folder where the config.yaml file is located?

How would i set the permissions for that folder?

Also now i am getting this error without the setup=“true”

I remove it and got this error when trying to run :

sudo docker run --rm -e --user $(id -u):$(id -g) --mount type=bind,source=“/home/diamonddog/.local/share/storj/identity/storagenode”,destination=/app/identity --mount type=bind,source=“/storjdir”,destination=/app/config --name storagenode storjlabs/storagenode:latest
[sudo] password for diamonddog:

Unable to find image ‘1000:1000’ locally
docker: Error response from daemon: pull access denied for 1000, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.
See ‘docker run --help’.

Also after entering “FALSE” in there got this error.

Well a string of these :

2023-01-30T00:53:15.571Z ERROR Invalid configuration. {“Process”: “storagenode”, “error”: “operator wallet address isn’t specified”}
Error: operator wallet address isn’t specified
2023-01-30 00:53:15,574 INFO exited: storagenode (exit status 1; not expected)
2023-01-30 00:53:16,576 INFO gave up: storagenode entered FATAL state, too many start retries too quickly
2023-01-30 00:53:17,578 WARN received SIGQUIT indicating exit request
2023-01-30 00:53:17,579 INFO waiting for processes-exit-eventlistener, storagenode-updater to die
2023-01-30T00:53:17.579Z INFO Got a signal from the OS: “terminated” {“Process”: “storagenode-updater”}
2023-01-30 00:53:17,583 INFO stopped: storagenode-updater (exit status 0)
2023-01-30 00:53:18,585 INFO stopped: processes-exit-eventlistener (terminated by SIGTERM)

I have been working on this as I wait and figured out that 1 of the steps in the directions is flawed… OR so I think.

But now I have gotten it to run and now when trying to go and view my NODES status by entering my local IP in my brouser i get nothing and then when i do the local docker command to see the status I am getting this ,

sudo docker exec -it storagenode /app/
2023-01-30T01:27:38.583Z INFO Anonymized tracing enabled {“Process”: “storagenode”}
2023-01-30T01:27:38.587Z INFO Identity loaded. {“Process”: “storagenode”, “Node ID”: "SENSORED "}
Error: rpc: dial tcp connect: connection refused

Does your node work?
You may check it by checking logs:

docker logs --tail 20 storagenode

The web dashboard will be available only on the same device by default. If you want to connect remotely, you can use this guide: How to remote access the web dashboard - Storj Node Operator Docs
If you want to have an access from your LAN only, then you can remove from the dashboard’s port mapping, i.e. it will look like -p 14002:14002 instead of -p To make changes you need to stop and remove the container and run a new one with all your parameters include changed ones.
To stop and remove the container:

docker stop -t 300 storagenode
docker rm storagenode

To run a new container you need to use your full docker run command with all your parameters, include changed ones.

When I do this i get an error
“Error response from daemon: No such container: storagenode”

There does seem to be a docker running however showings as docker0 with an IP address
but not sure whats going on now.

It does not look like any are running since when I do run “docker ps” i get
a list but nothing in it.

when I try to run the command again as shown below

sudo docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967/tcp
-p 28967:28967/udp
-p 14002:14002
–user $(id -u):$(id -g)
–mount type=bind,source=”/home/diamonddog/.local/share/storj/identity/storagenode",destination=/app/identity
–mount type=bind,source=“/storjdir”,destination=/app/config
–name storagenode storjlabs/storagenode:latest

This is the error i get

docker: Error response from daemon: invalid mount config for type “bind”: bind source path does not exist: /storjdir.
See ‘docker run --help’.

BUT there it is so why does it say its not there?

This is very frustrating. Not sure why someone does not come out with a easy to use self installing ISO w/Ubuntu just plug in params and go.

1 Like

you need to use

docker ps -a

to see all containers, not only running.

it looks like this folder is not in the root of the disk, but likely in your home directory.
Please show result of the command:

df --si -T

Today I followed the step-by-step tutorial as in the docs, and ran into the same error posted by OP while running the setup command I get

/app/config/config.yaml2933696436: permission denied

How did you get around this ?? I am not sure I want to go down OP route since he ended up with more problems that he started with

EDIT: if it helpt, it might be related to permissions in the freshly mounted disk?
I can’t create a directory inside it, only with sudo, otherwise I’ll get a permission denied.

EDIT2: fixed with sudo chown my-user:my-user /mnt/hdd14