Error response from daemon: driver failed programming external connectivity on endpoint storagenode

Hi, I noticed that at least two people on the forum were posting about this issue, but neither helped me in troubleshooting my issue. I just finished setting up the run command for the first time and when I run it, I get the following error message:

Error response from daemon: driver failed programming external connectivity on endpoint storagenode (4331a33d48a53055552fba31df169810346273792606b2d0cef3e95afc7fe91c): Error starting userland proxy: listen tcp 0.0.0.0:4001: bind: An attempt was made to access a socket in a way forbidden by its access permissions.

Not sure what to do about this. (also, if anyone thinks I should be deleting config.yaml from the storage location as suggested by Alexey in Docker: Error response from daemon: driver failed programming external connectivity I can’t find it with Search Everything and it’s not in the identify nor storage folders)

If you changed any setting in Hyper V You will need to open docker and reset all settings. Docker Doesnt like when you change any kinda settings like networking.

I haven’t changed anything lately, but I’ll try resetting settings and get back to you.

Nope. Same error occurred.

My reply got spam-blocked, so I apologize if this seems redundant down the road.
I haven’t made any changes to Hyper V as of late, but just in case, I reset Docker and ran the run command again afterwards. It’s still returning the same error as before.

What platform are you running your node on and what does your docker run command look like?

Running on Windows, here’s my command as it is.

docker run -d --restart unless-stopped -p 4001:28967 -p 127.0.0.1:14002:14002 -e WALLET="[censored]" -e EMAIL="[censored]" -e ADDRESS="[censored]" -e BANDWIDTH=“2TB” -e STORAGE=“500GB” --mount type=bind,source=“C:\Users\Bram\AppData\Roaming\Storj\Identity\storagenode”,destination=/app/identity --mount type=bind,source=“g:\storj”,destination=/app/config --name storagenode storjlabs/storagenode:beta

Docker on windows is not that stable yet. I would give the following things a try.

  1. Restart docker from the task tray
  2. If 1 didn’t fix it, restart the entire machine
  3. If that didn’t do the trick, reinstall docker

Keep in mind that you need to stop your node safely before trying each step.

docker stop -t 300 storagenode

BrightSilence, does Resetting docker from settings count for reinstalling it, or should I be fully uninstalling and reinstalling docker? (The standalone installer without having to make an account was a bit of a pain to locate)
Past that, everything you’ve suggested I’ve basically tried on my own in attempts to fix it, though I’ll try them again anyways and let you know if any progress is made.

I realize it’s cumbersome, but it’s still worth a try. The upside is that the windows installed should be available in 4 to 6 weeks. So things will be better then.

does Resetting docker from settings count for reinstalling

I would just se this as a factory reset.
Did that a couple of times when I ran Windows as host.
It did the trick everytime for me

Alright, I uninstalled and reinstalled Docker and encountered the same error as before. Same with after restarting the machine as well. It’s possible I’ll just have to wait those 4-6 weeks.

Just 4001 is already occupied.
Try another port, or better to use the default, 28967. Or any other, but not the 4001.
I think you have a storagenode v2 there too. So, please, skip all ports in 40xx interval.

1 Like

Changed the port numbers under -p 28967:28967 and address as well as edited the port forward on the router to that number as well and the same error code is still being returned.

Please, post the error after change.
Also, do you use the Docker toolbox or Docker desktop?
The Docker toolbox will not work.

So I was about to send you the updated error and for some reason this time it just worked. I wish I knew what happened that allowed it to suddenly work, but I haven’t made any changes since the last time I tried except for closing powershell. Thank you to everyone for helping me out.