Error signing the identity

Hallo everyone. I already have set up one node and it is working perfectly. When I now try to set up another node (new email adresse, new host etc.) I get stuck at the signing process. Machine is running Ubuntu 18.04.3. After the storagenode create command, I get 4 files in the .local/shared/… folder as expected. When I then start signing it it took quite some time. After breaking up I retry and get immediately the following error:

2019-10-04T13:34:00.966+0200 INFO running on version v0.22.1
2019-10-04T13:34:01.598+0200 FATAL Unrecoverable error {“error”: “error occurred while signing certificate: rpc error: code = Internal desc = certificates peer error: error claiming authorization\n(identity files were still generated and saved, if you try again existing files will be loaded)”, “errorVerbose”: “error occurred while signing certificate: rpc error: code = Internal desc = certificates peer error: error claiming authoriz …

As said, since I once broke up the process the above menthioned error occurs immediately. I then tried to totally start from scretch on a win7 machine with the corresponding windows-procress. This time I did not interrupt the process. After like 15min I receive the same error.

Can this be an issus of firewall? The 28967 port is open…

Are you using the latest identity binaries to create the identity? You can download it from We currently have similar reports from several other SNOs, and devs are looking into the certification process to see if there is a bug that needs to be fixed. You may want to sign up for a new auth token again just to be sure the problem is not with the token itself. During the identity signing, the status of your ports should not be an issue.

I used the latest binaries. The storj support told me to request for another token. with the new one it worked fine as ever.

1 Like

remember to SYNC your timezone, thats was the case in my case!

Ah. okay. How to do so, is their a Docker command regarding the Storj Container, or are you talking about the Linux system time. In both cases, could you give me a brief hint how to do so?

You need to sync your clock only to sign the identity with an authorization token.
So, it’s not related to the docker, it’s related to your system.

In case of Windows you need to have a installed and need to choose the nearest server from the

In case of Linux you should install the ntp:

sudo apt-get install ntp ntpdate -y
sudo service ntp stop
sudo ntpdate -s
sudo service ntp start
timedatectl status
timedatectl list-timezones
sudo timedatectl set-timezone <your timezone>
1 Like