ERROR trust Failed to fetch URLs from source {"source": "https://tardigrade.io/trusted-satellites",

Hi there,

I have just re-validated and attempted to re-deploy a Ubuntu/docker instance and am facing a frustrating error.

The docker logs show the following:

2021-04-08T16:15:48.886Z        ERROR   trust   Failed to fetch URLs from source        {"source": "https://tardigrade.io/trusted-satellites", "error": "HTTP source: Get \"https://tardigrade.io/trusted-satellites\": dial tcp: lookup tardigrade.io: Try again", "errorVerbose": "HTTP source: Get \"https://tardigrade.io/trusted-satellites\": dial tcp: lookup tardigrade.io: Try again\n\tstorj.io/storj/storagenode/trust.(*HTTPSource).FetchEntries:63\n\tstorj.io/storj/storagenode/trust.(*List).fetchEntries:90\n\tstorj.io/storj/storagenode/trust.(*List).FetchURLs:49\n\tstorj.io/storj/storagenode/trust.(*Pool).fetchURLs:240\n\tstorj.io/storj/storagenode/trust.(*Pool).Refresh:177\n\tstorj.io/storj/storagenode.(*Peer).Run:831\n\tmain.cmdRun:218\n\tstorj.io/private/process.cleanup.func1.4:363\n\tstorj.io/private/process.cleanup.func1:381\n\tgithub.com/spf13/cobra.(*Command).execute:842\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:950\n\tgithub.com/spf13/cobra.(*Command).Execute:887\n\tstorj.io/private/process.ExecWithCustomConfig:88\n\tstorj.io/private/process.ExecCustomDebug:70\n\tmain.main:385\n\truntime.main:204"}
Error: trust: failed to fetch from source "https://tardigrade.io/trusted-satellites": HTTP source: Get "https://tardigrade.io/trusted-satellites": dial tcp: lookup tardigrade.io: Try again

Port 28967 is enabled via ufw and the docker config is set up as outlined in the docs.

The previous node worked flawlessly until the end of the previous month. Then the docker container stopped due to a time-sync error for upwards of a few days (based on the docker log). After restarting, it subsequently went offline in the past week. Watchtower is enabled for the respective docker container.

Any insight is appreciated.
Cheers

This could be some kind of DNS error or anything else preventing your container from reaching the shown URL to fetch the trusted satellite list.

1 Like

Thanks for the quick reply.

I tried to manually set the docker container dns server to one of Cloudflare’s using the following additional parameter in the bash docker run command:

--dns=1.1.1.1

This did not change anything unfortunately.

Are there any additional firewall rules required beyond allowing traffic to port 28967?

I tried a method posted before which involved pulling the docker container, opening the docker container shell and attempting to download (using wget) the same ‘trusted-satellites’ html page. This worked fine.

Not sure what else to try at the moment.

1 Like

The documentation for Windows only refers to an inbound TCP rule on said port - Linux should require the same, but nothing else. I don’t run any Linux/Docker Storj nodes tho, so probably someone else might have something more useful to add :slight_smile:

1 Like

Have you tried restarting everything between your node and the internet? The only time I had problems with the docker container and DNS lookups, it ended up being a restart of my router that fixed it. Can’t tell you why, but that was the problem.

1 Like

Please, make sure that you uses storjlabs/storagenode:latest image, not :beta or :alpha

@baker : The server is hosted in a data center. I did consider a reboot but was a little reluctant due to other services running. I did however restart the docker service/socket and, to my surprise, the instance started without any hiccups.

sudo systemctl stop docker.socket
sudo systemctl stop docker.service

sudo systemctl start docker.service
sudo systemctl start docker.socket

@Alexey : Thanks for the suggestion. I checked through the parameters as well and the correct docker image was listed.

To be honest I am a bit concerned about any future watchtower updates of the docker image resulting in similar DNS issues…

1 Like

This is likely related to the updates or installation of some services.
The watchtower is a usual docker container, which is rarely checks the docker hub and updates running containers.

@Alexey : Thanks for the clarification. I should have been more clear: I’m concerned about the dependability of my setup in general :slight_smile:

I’ll report back should this event ever happen again. Hopefully I’ll have a bit more information from which to draw any definitive conclusions.

1 Like