Error while running the Gateway osx

Hi there,

I’m getting this error while running the gateway in mac osx catalina:

miguel@MacBook-Pro-de-Miguel S3 % ./gateway_darwin_amd64 run
2020-02-08T14:08:19.662+0100 INFO Configuration loaded from: /Users/miguel/Library/Application Support/Storj/Gateway/config.yaml
2020-02-08T14:08:20.593+0100 INFO running on version v0.31.12
2020-02-08T14:08:20.594+0100 INFO Starting Storj S3-compatible gateway!

2020-02-08T14:08:20.594+0100 INFO Endpoint: 127.0.0.1:7777

2020-02-08T14:08:20.594+0100 INFO Access key: W2vgTLQGZfBn1azhK3********

2020-02-08T14:08:20.594+0100 INFO Secret key: 2vDCLKzpCzab5P3Wm1********

Created minio configuration file successfully at /Users/miguel/Library/Application Support/Storj/Gateway/minio

API: SYSTEM()
Time: 14:08:20 CET 02/08/2020
Error: invalid argument
1: /go/pkg/mod/github.com/minio/minio@v0.0.0-20180508161510-54cd29b51c38/cmd/gateway-main.go:166:cmd.StartGateway()

Thanks in advance, regards.
Miguel

This is happened with me also when ever I want to run gateway in my mac it shows me error 0xe8000015 which I don’t know how to fix. If anyone can know the fixes ten suggest me.

Update: I also have this issue, as well as some other users. I can confirm that although this error shows up, the gateway does in-fact still run as normal, and you can simply ignore this error.

1 Like

Hey! We’re still investigating of course, but it hasn’t been a high priority because this appears to be a benign error? I am reproducing the same error on my Mac, but the Gateway still works as expected. I’ll report back if I discover how to get the error to go away.

Does the gateway not continue working for you, even with the error? Perhaps I’m not experiencing the same thing.

1 Like

Hello,

Yes I can see the listening port
tcp4 0 0 127.0.0.1.7777 . LISTEN

But when I tried to connect there is an error resolving the host:

[CRT] s3fs.cpp:set_s3fs_log_level(296): change debug level from [CRT] to [INF]
[INF] s3fs.cpp:set_mountpoint_attribute(4333): PROC(uid=502, gid=20) - MountPoint(uid=502, gid=20, mode=40755)
[INF] s3fs.cpp:s3fs_init(3450): init v1.85(commit:unknown) with GnuTLS(gcrypt)
[INF] s3fs.cpp:s3fs_check_service(3794): check services.
[INF] curl.cpp:CheckBucket(3250): check a bucket.
[INF] curl.cpp:prepare_url(4504): URL is https://127.0.0.1.7777/testqbucket/
[INF] curl.cpp:prepare_url(4536): URL changed is https://testqbucket.127.0.0.1.7777/
[INF] curl.cpp:insertV4Headers(2587): computing signature [GET] [/]
[INF] curl.cpp:url_to_host(102): url is https://127.0.0.1.7777

  • Could not resolve host: testqbucket.127.0.0.1.7777
  • Closing connection 0
    [ERR] curl.cpp:RequestPerform(2282): ### CURLE_COULDNT_RESOLVE_HOST

And still retrying in loop.

Have you any suggestion? thanks for your support

Best regards,
Miguel

I’m very confused about these two lines. First off, 127.0.0.1.7777? Don’t you mean 127.0.0.1:7777?
Secondly, why is curl changing the URL? This is puzzling. My guess is there is some small typo in your configuration (maybe the . vs : one)

Sorry this is a previous typo error in the CLI

I’m using s3fs to mount the bucket, this is the complete command

miguel@MacBook-Pro-de-Miguel S3 % /usr/local/bin/s3fs testqbucket /Users/miguel/Desktop/dumps -o passwd_file=/Users/miguel/.passwd-s3fs -o url=https://127.0.0.1:7777 -o dbglevel=warn -f -o curldbg
[CRT] s3fs.cpp:set_s3fs_log_level(296): change debug level from [CRT] to [WAN]
[INF] s3fs.cpp:s3fs_init(3450): init v1.85(commit:unknown) with GnuTLS(gcrypt)

  • Could not resolve host: testqbucket.127.0.0.1
  • Closing connection 0
    [ERR] curl.cpp:RequestPerform(2282): ### CURLE_COULDNT_RESOLVE_HOST
  • Could not resolve host: testqbucket.127.0.0.1
  • Closing connection 1
    [ERR] curl.cpp:RequestPerform(2282): ### CURLE_COULDNT_RESOLVE_HOST
  • Could not resolve host: testqbucket.127.0.0.1
  • Closing connection 2
    [ERR] curl.cpp:RequestPerform(2282): ### CURLE_COULDNT_RESOLVE_HOST
  • Could not resolve host: testqbucket.127.0.0.1
  • Closing connection 3
    [ERR] curl.cpp:RequestPerform(2282): ### CURLE_COULDNT_RESOLVE_HOST
  • Could not resolve host: testqbucket.127.0.0.1
  • Closing connection 4
    [ERR] curl.cpp:RequestPerform(2282): ### CURLE_COULDNT_RESOLVE_HOST
    [ERR] curl.cpp:RequestPerform(2387): ### giving up
    [ERR] curl.cpp:CheckBucket(3278): Check bucket failed, S3 response:
    [CRT] s3fs.cpp:s3fs_check_service(3874): unable to connect(host=https://127.0.0.1:7777) - result of checking service.
    [ERR] s3fs.cpp:s3fs_exit_fuseloop(3440): Exiting FUSE event loop due to errors

I guess s3fs is using curl to connect

Pretty sure the gateway doesn’t run over https. Also, s3fs seems to assume vhost paths, which is why the translation of that url happens. I’m not familiar with using s3fs myself, but you should look for an option to turn off vhost paths or enable direct path style.