Failed audit on new satellite according to api but nothing in logs

Hello, so I checked the forums today and noticed there was a new satellite added. I decided to check the audits for the new satellite on my node and I found strange that there was 1 failed audit. I went ahead and checked my log files but I don’t see any failed audit on it. Can someone point me to where I can look for this failed audit. Note, I have all my node logs since it first began.

Picture of log file


You should add failed to that grep command to catch that log entry.

I believe this to be an error in storj software, below is my logic for this statement. If I am completely mistaken, what would be the correct method for finding the error. Adding failed to the grep command produces no results.

First, I search for all audits done by this new satellite, whether failed or not with command "cat /mnt/storj/node.log | grep “AUDIT” | grep “12rfG3sh9NCWiX3ivPjq2HtdLmbqCrvHVEzJubnzFzosMuawymB”

My logic tells me there should be an even number of entries, one when the audit was initiated and the second when the audit either passes or fails. In my log files I have a total of 87 entries so definitely something is wrong.


Looking through the log I find that there was indeed an audit that was started and never finished

Now I just go through my entire log file and look for all mentions of this piece. It shows when I first got the piece and when and audit was attempted on it but never finished.

Lastly I search if the piece exists in my hard drive and it does

@Alexey your insight please.

We would need the NodeID to find it in the logs.

ID 122PeurKoiakUWXjgixZVCp5MMoS8PSt6YAzetGmauZhtaui6WX

T: “2020-04-19T19:33:30.321Z”
error: “usedserialsdb error: database is locked; piecestore: (Node ID: 122PeurKoiakUWXjgixZVCp5MMoS8PSt6YAzetGmauZhtaui6WX, Piece ID: B3YNWPKVHMXXOSNXIXBYHIAGTJQWO334MKFGQUE6VY5U5WKSKM3A): usedserialsdb error: database is locked”

so database locked is audit failure?

It falls under the category “unknown audit errors”: Design Draft: Storage Node "Suspended" State

So nothing to worry about other than the 98% Audit rate right now on my dashboard T-T, thank you for the information.

That is not exactly what is happening. You can get disqualified for:
Audit score lower than 60%. alpha / (alpha + beta)
Suspension mode (currently you don’t get DQed for that but soon you will)

The audit rate on the dashboard has nothing to do with any of these. You can get DQed while the dashboard is showing 100% audit rate simply because it is showing something that has nothing to do with the rules we use for DQ.


Okay but from the looks of this error, there is nothing really I can do because the node hard drive is in good health and the piece that failed to be retrieved is present on the hard drive. I tried coping the piece somewhere else and the process completed without problems. Any things I can look into to see what cause this issue, might it have been an internet disconnection?

I also show a 98.8% audit on dashboard for this new sat but 100% for every other one.
I have had zero downtime or issues.

When I run I show 100%

Node ID: 12HHiL6CSCTSGRZqprDvwtGJeusKv88wiBdnYQd1KaW12br3c15

Are there any other checks I should do. I don’t like it not being 100% especially if I as a SNO didn’t do anything wrong…

Same deal
T: “2020-04-21T00:56:37.445Z”
error: “usedserialsdb error: database is locked; piecestore: (Node ID: 12HHiL6CSCTSGRZqprDvwtGJeusKv88wiBdnYQd1KaW12br3c15, Piece ID: BNENENRJCD75XXNORE4T644KLBKE2R4POXWWRFW6FQQHV4HVSLSA): usedserialsdb error: database is locked”

T: “2020-04-20T16:56:27.830Z”
error: “usedserialsdb error: database is locked; piecestore: (Node ID: 12HHiL6CSCTSGRZqprDvwtGJeusKv88wiBdnYQd1KaW12br3c15, Piece ID: WTLU7NWPSLVGIZVXESVV6YQX5LU3VTEAZFYOKOA5ZDT5R2DDAW5Q): usedserialsdb error: database is locked”

Note: I didn’t check the entire log. I just copied the first few error messages.

I have the same problem with the dashboard, it shows an Audit score of 96.7% but the API reports an audit score of 1.00 so this is just a dasboard problem. Also no failed audits in my logs.

1 Like

I have brought this to the attention of the SNO growth team. They will be making the necessary adjustments to the dashboard to properly display the audit score as shown in the API in a future release.

1 Like

Ok So I am confused. Is there an issue with my node?
Is there anything I should do?
Is this a satellite issue or a dashboard issue?

What is the appropriate way to check my node for a missed audit that will hurt my reputation, lead to suspension, or worse disqualification when I did nothing wrong?

Your node did not respond to an audit request. Instead, it returned an error message.

As long as you don’t get suspended there is nothing you have to do. Ofc you could still try to find out what is going on regardless of the question if you might get suspended or not.

The dashboard issue is a different topic. As described above the values you see on the dashboard have nothing to do with the question if you might or might not get suspended or disqualified.

You can search in your logs for these pieceIDs. That might be a good starting point.

@rml52 & @xyphos10 How is your HDD connected ?