Failed to load identity - node keeps restarting

Hey everybody, my holiday nightmare finally happened. Just got back to check how it was the node and found out it was loop-restarting again.

  1. editing the config.yaml file info TO debug
  2. running a docker logs storagenode 2>&1 | grep -B 3 -i fatal
  3. It gives me this repeated message (actually i got it also from a simple docker logs)
  • failed to load identity "identity/identity.cert", "identity/identity.key": cert chain length error: identity chain does not contain a CA certificate

(My identity folder is located as usual into .local/share/storj/identity/storagenode )

  1. Using a docker ps -a
    it gives out two running services as following:
    c16214a8e348 storjlabs/storagenode:arm "/entrypoint" 9 minutes ago Restarting (1) 9 seconds ago storagenode
    8c30e1e5340a storjlabs/watchtower:latest-arm32v6 "/watchtower storage…" 2 months ago Up 27 hours watchtower

  2. If I try to run the dashboard.sh it says
    Error response from daemon: Container c16214a8e3484c41998eeaeda58c339b04746369aa1eb2d45c2b194dc5cabff7 is restarting, wait until the container is running
    [UPDATE]Also if I try to execute dashboard right after docker run it gives me this very unknown:
    OCI runtime exec failed: exec failed: container_linux.go:338: creating new parent process caused "container_linux.go:1897: running lstat on namespace path \"/proc/2600/ns/ipc\" caused \"lstat /proc/2600/ns/ipc: no such file or directory\"": unknown

my identity folder is all good, nothing different from before. I don’t really want to restart again, it has been 3 months now and July was a very good month.
I can get we are in beta, I can accept everything but it’s very odd that a SNO update every single time put my node in this situation…
Please help!

Please, post your docker run command

Also, please, check your autoupdate command, it has been changed: https://documentation.storj.io/setup/software-updates#automatic-updates

sudo docker run -d --restart unless-stopped -p 28967:28967
-e WALLET=“MYWALLETADDRESS”
-e EMAIL="aaa@mail.com"
-e ADDRESS="(MYIPNUMBER):28967"
-e BANDWIDTH=“100TB”
-e STORAGE=“1.8TB”
–mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode",destination=/app/identity
–mount type=bind,source="/mnt/storagenode",destination=/app/config
–name storagenode storjlabs/storagenode:arm

Also I checked the watchtower and resubmitted it too… still same errors when running storagenode

Please, copy the output of the commands:

df -h
ls -l /home/pi/.local/share/storj/identity/storagenode

Hey there,
i had the same problem so i can submit how i solved my Problem:
My Identity was on the “/home/USERNAME/.local/…” Dir and my node keep restarting and restarting …
I copied my ID-files into “/storj/id/” and set the “” param. to “/storj/id”.
After that i do “docker stop storagenode” then “docker rm storagenode” and after all i re-runed the install script with the new ID-Dir.
After That it worked just fine

To create a dir on / use your terminal and type “mkdir /YOUR-DIR-Name” and then “chown YOUR_USERNAME YOUR-DIR-Name”
after that press F5 and wolla

Tip:

Look at permissions of your Files and set also the Dir-Perm.

1 Like

Hello @abc,
Welcome to the forum!

Thanks for the tip!