Fatal error at storage node

hi I have the node offline , I check de ports and I reboot system(w10) and the server gui ,but the server still offline ,the log show me that

2020-06-20T02:59:16.606+0200 ERROR piecestore:cache error getting current space used calculation: {“error”: “context canceled; context canceled; context canceled; context canceled; context canceled; context canceled”, “errorVerbose”: “group:\n— context canceled\n— context canceled\n— context canceled\n— context canceled\n— context canceled\n— context canceled”}

2020-06-20T02:59:17.018+0200 FATAL Unrecoverable error {“error”: “debug: http: Server closed”, “errorVerbose”: “debug: http: Server closed\n\tstorj.io/private/debug.(*Server).Run.func2:108\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}

today I have so much troubles with the movistar connection but now they solved , but when I check the server ,it still offline , it was online since 15 may
( I know my English is not as good as it should)

Welcome to the forum @javtolt!

Try this checklist:

Hi ty for help me, I check all this things

  • Make sure the WAN IP you see in your router settings matches the IP shown on the above page.
  • Make sure your port forward is set up correctly. That means no filter on incoming IPs, forwarding to the IP of your node on the local lan. Set to TCP and port 28967.
  • If you’re running a firewall, make sure you allow incoming traffic on port 28967.
  • Make sure you’re not blocking any outgoing traffic from your node’s IP to any port. Make an explicit rule to allow that if needed.

but I dont know how to check the identity bcs I dont have docker

Did you try executing the commands given in powershell for Windows ?

https://documentation.storj.io/dependencies/identity#confirm-the-identity

The first command return 2, and the second command return 3 but I didnt try any more command

Good then your identity is properly signed. Did you check all other options :arrow_down:

Yes I’ve check it all of them, and On https://www.yougetsignal.com/tools/open-ports/?port=28967 I get the port check open
if I uninstall the gui storj and reinstall it , I will loose it all?

I check the log today and I saw this extra lines :
2020-06-20T03:00:34.218+0200 INFO Public server started on [::]:28967
2020-06-20T03:00:34.218+0200 INFO Private server started on 127.0.0.1:7778
2020-06-20T03:00:34.219+0200 INFO trust Scheduling next refresh {“after”: “8h40m39.13464091s”}
2020-06-20T03:00:34.218+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T03:31:17.922+0200 INFO Interrogate request received.
2020-06-20T04:00:34.233+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T05:00:34.227+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T06:00:34.229+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T07:00:34.220+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T08:00:34.226+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T09:00:34.232+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T10:00:34.219+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T11:00:34.223+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T11:41:13.863+0200 INFO trust Scheduling next refresh {“after”: “5h44m53.74508084s”}
2020-06-20T12:00:34.220+0200 INFO bandwidth Performing bandwidth usage rollups
2020-06-20T13:00:34.223+0200 INFO bandwidth Performing bandwidth usage rollups

Thanks in advance :slight_smile:

hi I´ve check that with this code I get a diferent Ip that I get from the https://www.yougetsignal.com/tools/open-ports/?port=28967 and from the router

code : Select-String “contact.external-address:” “C:\Program Files\Storj\Storage Node\config.yaml”

the noip duc its running correctly but I think that I used in the gui the ip like 185.105.38.27:28967 insted of my.ddns.net:28968 or something similar , how can I check that? or how can I change it ?

You can change the contact.external-address: to my.ddns.net:28967 and restart storagenode using

Restart-service storagenode

Remember the port is 28967 and not :arrow_down:

Unless you have 2 nodes.

1 Like

was the ip , I used the ip insted of the ddns direction

ty :slight_smile: the port was an error in the last post sorry about that
really thank you very much @nerdatwork :slight_smile:

2 Likes