Filezilla error "failed to parse access: uplink: api key format error: invalid macaroon version"

Hi there,

i am trying to get my Filezilla connected to Storj. But when i try to connect i get this message:
failed to parse access: uplink: api key format error: invalid macaroon version
image
Anyone knows what is wrong?

I am also curious about this. I’ve spent two hours so far to solve this problem without any success. Furthermore, I had the same output every time, no matter what I tried.

I don’t think you are doing anything wrong. Storj changed how the access keys are presented in the GUI on the satellite and these are no longer compatible with those fields in FileZilla. Someone mentioned that FileZilla are already working to change it their end to match the new security access from the Satelite gui.

I’ve not been managed very well to say Storj advertise FileZilla as a partner.

Please, try to generate a token instead of normal access grant:


This token is compatible with API key expected by FileZilla

Don’t get me wrong but why is the partnership been advertised as this is not working as intended?

This make the accessibility to tardigrade a bit difficult for the non tech people.

I mean I can create a token no problem. But why is this not being fixed? Why is the change not giving to FileZilla and later on implemented?

1 Like

The FileZilla always takes an API key as a configuration parameter, so nothing has changed too much - we still have a legacy token generation.
We cannot really control the speed of development in a third party products. The new version should be able to consume an access grants too, but seems it’s delayed.
We also can offer the Gateway MT (carefully - beta!) which you could use as an S3-compatible backend for Tardigrade:

Alright very cool I will look into this thanks for the clarification Alex.

Really want to check if tardigrade can help me with my backup systems for my company.

Currently backing 300GB a day and I need some storage that is not a single point of failure.

Well… tardigrade is perfect for it!

1 Like

Then maybe you can take a look on other backup solutions:



https://documentation.tardigrade.io/how-tos/sync-files-with-rclone

If you have a Kubernetes, you also can take a look on:

I am having the same issue as the OP and have followed the instructions to create a token yet I get the same error when attempting to connect in FileZilla. Any other suggestions?

Hello @nutman,
Welcome to the forum!

Please, clear a browser cache and cookies, then generate a token: https://documentation.tardigrade.io/getting-started/generate-access-grants-and-tokens/generate-a-token and use it as an API key in the FileZilla