Filezilla Pro no files

Good evening,

I’m playing a little bit around with Storj.

I have greated some buckets with the browser. Then I generated access to the buckets also with the webgui.
After a backup with duplicati to a bucket was greated, I tried to connect to the bucket with the filezilla. There are no files showen(only the different buckets). Also with the androidapp Bucketanywhere.

Whats wrong?

Make sure you use the same encryption passphrase otherwise the objects won’t be visible.

i have the same passphrase but don’t see the files only the different buckets.

with this uplink ls sj://nextcloud --encrypted i can see the files

Then you haven’t used the same passphrase as when you uploaded them.


thanks when I tried to delete the bucket, I get The bucket you tried to delete is not empty in the browser.

per cli uplink rm sj://synologyhomedaniel

Error: uplink: object key invalid ("")

To remove a bucket you should use rb instead of rm. You can use the --force flag to remove non-empty buckets. Alternatively you can use rm with the --encrypted flag to remove encrypted objects.

Make sure to always keep your pass phrases stored somewhere safe. Without them you can never get access to the original objects again. All you can do is delete those objects.


that mean the best solution is one encrypt passphrase for all projects/access?

I can’t really answer that. It’s really dependent on your project requirements. But I can imagine that you might want to use different passphrases for different users. Like if you use Storj as a backend for an app you could use a pass phrase derived from the users password to encrypt their files and ensure that you as a developer don’t even have access to their files.

If it’s just your personal backups, then yeah, one passphrase is probably easiest. But I think having it be possible to use all different passphrases opens up a lot more options.


I have one last question, is the best way to backup with s3 compatible server?

I would recommend to use a native configuration options for them instead of S3.
Because when you use S3, it’s server-side encrypted unlike native client-side encryption