Getting More Information from CLI Storage Node

I’ve setup Ubuntu Server on one of my servers and installed docker along with storjlabs/storagenode:beta I got everything setup and ran docker exec -it storagenode /app/

This works and gives me almost all the information I want but I’d like to see a day by day record of Ingress:Egress traffic since it seems storjlabs/watchtower does not always do it’s job. My storage node in previous testing has failed to update as it should causing Ingress:Egress to drop to 0 but I can’t clearly see if that occurs from the CLI version of dashboard.

Is there a CLI utility for viewing day by day traffic or any argument I can add to view this information?

localhost:14002 web dashboard, give you graph with every day point, Egres and Ingress,
even for every Satellite.

I’m using Ubuntu Server. No GUI. CLI only. I’ve tried remoting into the WebUI by pointing my desktops browser to the servers IP:14002 but all I get is a refused connection.

do you have firewall on node?
what is your docker init string?
I have also on node on raspberry pi, with docker, and it by default has Web dashboard acceseble from network.

Default Ubuntu Server installation. If there’s a firewall it’s running by default I’ve not configured any.

Don’t know what that is.

Not working for me on Ubuntu Server.

did you done this?
sudo ufw enable

Add -p 14002:14002 to your docker command, and then open that port up on your firewall. I have a Ubuntu node that I connect into using the dashboard and this works for me. Using localhost in the -p command will limit connections to just the local host.

Tried it. Made no difference.

this command activate your firewall, you need to allow in firewall.
@cwilkins can you assist how to open port on Ubuntu firewall?

Yep, here is what you need to do to enable that port.

sudo ufw allow 14002

If you don’t have ufw installed, install it using sudo apt install ufw

You might also have to enable the other port for SNO, if you install ufw. So here are the rest…
sudo ufw allow 26967 (I think that is the default port for SNO. I run on custom ports)

Adding -p 14002:14002 but going to restart storagenode:beta docker threw an error.
Replacing -p with -p 14002:14002 I now have remote access to the WebUI.

This is an edit to the launcher I’ll have to remember to make for the future.

That error makes sense, as you can’t have the same port in twice. But it looks like you are all fixed up.

I would not mind enabling a firewall just to prevent any hijacking. UFW is installed by default on Ubuntu Server but it’s also disabled by default.

I’m going to make the assumption enabling it blocks all(most) ports then I make exceptions for the ports that I want allowed correct? (as the commands you outlined state)

That is mostly correct. It seems to know some of the standard ports, and opens them up, but for SNO you’d have to add the exceptions. If I were doing this, I’d watch the port status using a port scanner from the web and make sure it comes up once you run the command. I’ve not had trouble doing this, but always check.

Went ahead and enable UFW and opened ports 22, 7778 (CLI dashboard seems to use it), 14002, & 28967. Everything is working.

I did want to see if blocking a port again make a service stop working but blocking 14002 does not prevent me from remoting in…

I think that is internally only, but I could be wrong.

What command are you using to block port 14002?


sudo ufw deny 14002

Looks good to me. Also enable the firewall using sudo ufw enable

Sometimes it is not turned on by default.

It was not when we started. Oh well, it’s on. Everything still works. With any luck it will still protect against something. Thanks for the help.

If you want to learn more about ufw here is a good link that goes into some details on the commands, and some advanced settings like limiting access to only particular IPs, etc.

Glad we could help!