Getting started with Storj V3 Local Test Network (storj-sim)

But pi@raspberrypi:~/up/storj/web/satellite $ storj-up credentials
Gives above error about retry in 1sec

This error
Server is not yet available. Retry in 1 sec… rpc: dial tcp [::1]:7777: connect: connection refused

You need to start all services before invoke storj-up credentials:

docker compose up -d

Then when all services will be started, you can call

storj-up credentials

To check services:

docker compose ps

There all services should not have errors

I did they say exited on second command on first command all but one say started the other says running could it be that the pi is starting them just extremely slowly so they are currently started but not running yet

You need to wait longer. On my x86 laptop with i7 it is fully started after a minute.
Just make sure that there all services are running:

docker compose ps

Cool thought so thanks

I made a .sh script to run all the commands and the PS command says running for 2 but if i check again by typing
Docker compose PS again
It then says the are exited again

After a whole night still only redis started Now even redis says exited

Perhaps not enough RAM.
If service shows “exited”, then it will not restart. You need to start them

docker compose up -d

To make it easier on my hardware maybe even faster can i use docker start x- whatever package name for all

The short answer is no.
You can start independent services such as uplink, storagenodes, even gateway, but all remained are considered as a “satellite”.
As I said many times, the satellite consist of several services, it’s not a single package.

I know it’s atleast 3 API, admin , and CMD (maybe) but why can i not start all of them separately docker lets me so why will it not work do all packages need to be launched together so they can access each other is this why?

Dependencies…
You may try to run them one by one, or modify the docker-compose.yaml generated by storj-up init to use clause depends_on, see compose-spec/spec.md at 5260c1bc8ee5e93ce88412bb460924e9535d9080 · compose-spec/compose-spec · GitHub
I do not know the right sequence, so you need to experiment yourself.
But redis and database (cockroach) should be started first.
Perhaps:

  1. redis
  2. cockroach
  3. versioncontrol
  4. satellite-core
  5. satellite-api
  6. satellite-admin
  7. authservice
  8. linksharing
  9. gateway-mt
  10. storagenode
  11. uplink

Ok thanks will try this

Is it possible that somehow docker-compose ps is wrong because starting them individually it still says they exited but if i try start the same one again it says about the port already being bind to wouldn’t that mean it’s running if it has bound to the port

You need to use docker compose up -d to start services, not something other.
However, docker start up-satellite-api should work too. The only docker run will not work, or if you would initialize another folder with storj-up.

If i do docker-compose up -d && docker compose ps
It shows them running but if i run docker PS manually only redis is running
I also tried adding swap ram but it didn’t help

What is docker-compose up without the -d it seems to make more fun but gives an error

x-storagenode-5 | exec /var/lib/storj/entrypoint.sh: exec format error
x-storagenode-10 | exec /var/lib/storj/entrypoint.sh: exec format error
x-linksharing-1 exited with code 1
x-storagenode-3 | exec /var/lib/storj/entrypoint.sh: exec format error
x-satellite-api-1 | exec /var/lib/storj/entrypoint.sh: exec format error
x-storagenode-7 | exec /var/lib/storj/entrypoint.sh: exec format error
x-satellite-core-1 | exec /var/lib/storj/entrypoint.sh: exec format error
x-storagenode-1 exited with code 1
x-storagenode-6 exited with code 1
x-authservice-1 exited with code 1
x-uplink-1 exited with code 1
x-storagenode-4 exited with code 1
x-storagenode-2 exited with code 1
x-versioncontrol-1 exited with code 1
x-satellite-admin-1 exited with code 1
x-storagenode-8 exited with code 1
x-storagenode-9 exited with code 1
x-storagenode-5 exited with code 1
x-storagenode-10 exited with code 1
x-satellite-core-1 exited with code 1
x-satellite-api-1 exited with code 1
x-storagenode-7 exited with code 1
x-storagenode-3 exited with code

And if i try cd to that path (car/lib/storj) it doesn’t exist

pi@raspberrypi:~/x $ cd /var/lib/storj
-bash: cd: /var/lib/storj: No such file or directory
pi@raspberrypi:~/x $ cd /var/lib
pi@raspberrypi:/var/lib $ ls
alsa docker PackageKit systemd
apt dpkg pam ucf
bluetooth git polkit-1 unattended-upgrades
containerd logrotate private usb_modeswitch
dbus man-db python vim
dhcp misc raspberrypi
dhcpcd nfs sudo
pi@raspberrypi:/var/lib $

The error is happened inside the container, not on your host, so you will not see these files on your host system, because they inside the container.
Seems prebuilt images doesn’t contain the image for your platform. You can try to setup to build it:

storj-up build remote github storj

Then

docker compose up

It should build required images for your platform.

That did this

sudo docker-compose up
[+] Running 0/11
⠿ satellite-core Error 3.8s
⠿ linksharing Error 3.8s
⠿ app-storj Error 3.8s
⠿ uplink Error 3.8s
⠿ authservice Error 3.8s
⠿ app-edge Error 3.8s
⠿ gateway-mt Error 3.8s
⠿ satellite-admin Error 3.8s
⠿ storagenode Error 3.8s
⠿ satellite-api Error 3.8s
⠿ versioncontrol Error 3.8s
Error response from daemon: pull access denied for storj, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied
pi@raspberrypi:~/x $

Then it seems cannot be used on ARM platform.
Seems you have to use only storj-sim