Graceful Exit on Synology NAS (Container Manager)

I am running three nodes on 3 different computers at home. I realise that storj treats them as one node and was / am fine with that. I was mostly running them on different setups to see how things worked out.

The synology node just causes me issues - and slows the NAS down too much (GUI in particular - its not a new synology). I did add a SSD for the database which improved things substantially.

I would like to gracefully exit the Synology Storj Node - but don’t see how to. I am not using a command line - but the synology Container Manager (I also have access via Portainer)

How do I add the exit-satellite command?

1 Like

Out of interest, can you not move the node to a different machine instead of losing the data you’ve already accrued on it? :slight_smile:

1 Like

Also read


Because running 3 nodes off 1 IP address is a bit silly AND I only have 3 24*7 machines that are capable. I don’t need the space back - it just doesn’t run well enough.

The held amount is only $8.61 - so it ain’t that important.

Thats doesn’t tell me how to do it.

Its a kind generic “docker exec -it storagenode /app/storagenode exit-satellite --config-dir /app/config”

The thing is - whilst I may have a command behind the scenes - I don’t seem to have one I can interact with. I can:

  • Change Ports
  • Change Volumes (of which I have three)
  • Change Environment Variables
  • Change Capabilities

If I manually run the docker exec command the chances of me getting it correct are minimal and the node will likley get DQ rather than exited.

Well, but that was my point: move the HDD (or data) to one of the 24/7 machines and have it run both nodes?

Just a thought :slight_smile:

I could I suppose rsync the data across to one of the TrueNAS boxes. But given the recent Storj changes it doesn’t seem worth the bother.

On the subject of how - I may be misunderstanding what the docker exec command does. I thought it ran the docker container (I always use GUI’s for containers) - but in fact it runs a command inside the container. That makes more sense

Turns out I had no idea what I was asking about - its seems its really easy once I worked out that that docker called my node fd185d87c996 rather than something useful