Gracefull exit for over a month in 0%

I would like to do gracefull exit to my nodes.
i have 3 of them.
i gave the command in my synology
storagenode exit-satellite and after i gave one by one all satellite domain names
i checked and the command was delivered…(by trying the same procedure again it didnt find any sattelite available to exit)

it is a month after and every time i try to check the status with the command
docker exec -it storagenode /app/storagenode exit-status --config-dir /app/config --identity-dir /app/identity
i see the progression is at 0%

what did i wrong? please help!

The percentage field doesn’t change anymore: you’re only watching for “Successful = Y” now. Perhaps give it a couple more days?

1 Like

I think you should check the logs, because when the command is given the screen will not update. The terminal screen is not captured on the progress basically.

I post the terminal screen capture!

Hello @jimpapi,
Welcome back!

You need to search for grace in your logs.
However, if the command has been succeed, the final state would be either 100% and Y or 0% and disqualified on your dashboard after the end of the GE.

i didnt find any “grace” in my logs…

I tried the command again and this is the result:

When you remove the container, the previous logs will be gone, so if you started more than a two weeks ago, likely the logs were cleaned up already.
Then you need just wait until it would finish.

i gave up. I waited 37 days… I shut down my servers and my nodes without graceful exit. I can’t understand what went wrong.
Generally i had many problems with my nodes under docker in my synology nas. Now i created new storagenodes in windows environment, with the Win GUI Storj Node Toolbox given.
Since now (2 days running) no problem at all. No stops , no dropdowns without reason…easy installation for multiple nodes. I had many problems with docker and had to restart the nas and the nodes 2-3 times per week. In windows 11, everything looks so steady…i also created a task to check my node status and if down to restart the server automatically, so i don’t bother to controll all the day as i did when newbie

What’s exit-status said?

Interestingly, I went opposite direction. I shut down Windows node and turned on Synology node.
The reason - as discussed here, after the node size went over some 12 TB, on NTFS with all possible improvement settings, the filewalker becomes nevereding story - never completes its job.
But you may be more lucky :wink:

one node per HDD…

1 Like

I am sorry but i deleted the os and setup windows 11. No more access to docker…

My nodes are up to 12GB. i have 3 of them. I run windows 11 latest version and i avoid the storj installation completely. I found the Win GUI Storj Node Toolbox much faster and better. I would say more stable. My nodes are up for a week and everything works fine. I am in vet period ofcourse so my traffic is still low. But non stop running of all of my nodes for more than 7 days was something very rare in synology docker…they where drop down without a reason probably from irregular storj pieces in download or in upload.

1 Like