Has my node been vetted yet?

hello everyone,

i’m new to the whole linux game and i’m still dabbling with a raspberry pi 4.
i have a storj node that has been running for almost 2 weeks and was averaging 2gb egress daily which seemed to be normal as the vetting process was still ongoing.
today i noticed a hike in the egress and i’m wondering if this means that the vetting is finally done and i can start receiving some decent traffic ?
my setup is very simple, a rpi4 4gb with 1.4tb hdd , 1gb speed and unlimited bw.
i tried to look for any simple commands that i can run to see the sucess rate but being a noob has made it a lot harder than it may sound to some of experts here.
sto scr

1 Like

I would say no normally takes over a month to get out of vetting.

1 Like

thanks for the reply, but how do i know for sure ?
is there any simple command i could run ?

1 Like

Yes, it usually takes a little longer. We all saw an increase in egress I think. At least I did and I saw @vadim mention it elsewhere as well.

I’ve expanded functionality of the earnings calculator to include vetting progress if you want to have a look where you’re at yourself.

3 Likes

No, Nothing simple to run you would need to run a script, vetting you need at least 100 successful audits though.

1 Like

Welcome to the forum @max!

Remember to use only 90% of available free space and keep 10% as overhead.

1TB HDDs NEVER have 1000GBs of actual free space.

1 Like

for sat in wget -qO - localhost:14002/api/dashboard | jq .data.satellites[].id -r; do wget -qO - localhost:14002/api/satellite/$sat | jq .data.id,.data.audit; done

2 Likes

thanks for all the inputs but how do i run this ?
for sat in wget -qO - localhost:14002/api/dashboard | jq .data.satellites[].id -r ; do wget -qO - localhost:14002/api/satellite/$sat | jq .data.id,.data.audit; done

1 Like

the same way you issue the command “docker run -d --restart unless-stopped …” etc.

1 Like

the forum software ate some characters. Try

for sat in $(wget -qO - localhost:14002/api/dashboard | jq .data.satellites[].id -r) ; do wget -qO - localhost:14002/api/satellite/$sat | jq .data.id,.data.audit; done
1 Like

@donald.m.motsinger I’ve tried to run this commant - absolutely nothing happens :expressionless:

But i believe it should show is the node vetted or no?

1 Like

Not even an error message? Try to run some parts of the command
wget -qO - localhost:14002/api/dashboard
and
wget -qO - localhost:14002/api/dashboard | jq .data.satellites[].id -r
Do you get any output? Then try with one of the satellites, which you got from the last command
wget -qO - localhost:14002/api/satellite 118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW | jq .data.id,.data.audit

The last command is one line.

1 Like

@donald.m.motsinger same as @nodeX nothing happens when i run that command.
even breaking it up does nothing.

1 Like

Do you have the api enabled? Do you have -p 14002:14002 in your docker run command?

no idea about the api but here’s my docker run:

docker run -d --restart unless-stopped -p 28967:28967
-p 127.0.0.1:14002:14002
-e WALLET=“xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”
-e EMAIL="xxxxxxxxxi@gmail.com"
-e ADDRESS=“xxxxxxxxxxxxxxxxx”
-e BANDWIDTH=“60TB”
-e STORAGE=“1400GB”
–mount type=bind,source="/home/pi/identity",destination=/app/identity
–mount type=bind,source="/home/pi/storage",destination=/app/config
–name storagenode storjlabs/storagenode:beta

thanks for your time mate

ok we are getting somewhere now, but what does it mean ?

“118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”

“totalCount”: 24,
“successCount”: 24,
“alpha”: 14.45220853756331,
“beta”: 0,
“score”: 1

“121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6”

“totalCount”: 101,
“successCount”: 101,
“alpha”: 19.89313444757295,
“beta”: 0,
“score”: 1

“12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S”

“totalCount”: 95,
“successCount”: 95,
“alpha”: 19.854622865807727,
“beta”: 0,
“score”: 1

“12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs”

“totalCount”: 45,
“successCount”: 45,
“alpha”: 18.110635117245227,
“beta”: 0,
“score”: 1

totalCount and successCount are the (successful) audits. You need 100 to be vetted per satellite. So you are vetted on one satellite and almost on another at the moment.

2 Likes

@max how did you get this?

What command did you run?

Thank you.

@nodeX I had to: sudo apt-get jg
Then once jq is installed I ran: for sat in docker exec -i storagenode wget -qO - localhost:14002/api/dashboard | jq .data.satellites[].id -r; do docker exec -i storagenode wget -qO - localhost:14002/api/satellite/$sat | jq .data.id,.data.audit; done

yeah… i’ve installed jq too, but when i run your command:

for sat in docker exec -i storagenode wget -qO - localhost:14002/api/dashboard | jq .data.satellites.id -r; do docker exec -i storagenode wget -qO - localhost:14002/api/satellite/$sat | jq .data.id,.data.audit; done

I’ve getting this error: -bash: syntax error near unexpected token `|’

:frowning: