Have to reboot each morning

Hi everyone. Have a question about my node using the Windows GUI on Windows 10 Professional. Node actually is fine, with no problems. What isn’t fine is that pretty much each morning I can’t get my emails, resolve a website with out first rebooting my computer. It is almost as if my router is getting overloaded (?). Using Tmeter I tried to lower Storj internet usage - makes no difference. Not a computer professional so go easy. Any thoughts?

Welcome to the forum @RonRPh!

Are you having issues with computer being stuck or having no internet to use for other services ?

Might be an arp cache problem.

How to flush the ARP Cache Windows 10

Computer is not stuck. It just seems to have a problem resolving website addresses, and also getting emails. It will eventually “find them”, but it takes awhile. I don’t know whether to try that ARP cache flush or not. Sounds a bit scary ( might try after a full backup- usually do that the first of the month).

The ARP cache is simply a local address list of common IPs… for most LAN hosts, it’s simply a few entries and doesn’t change much. However, on routers, the ARP cache can get a bit mixed up when there have been lots of traffic to and from many Internet addresses.

I’ve had routers that needed the ARP cache cleared every day or so… it’s possible that your Windows machine and/or your router is getting overwhelmed with the many different clients connecting to your Storj node.

Clearing the ARP cache will not hurt the machine, the cache will rebuild quickly… it might not be the problem, but it shouldn’t hurt to give it a try.

You can try and set the DNS Servers manually on your NIC to: and and see how that works.

Okay beast I gave it a try. I won’t know till I guess tomorrow now. Oddly it seems to work fine all day long and then when I don’t use the computer, I seem to get the problem. naxbc - thank you replying. At this point I’m giving the ARP thing a try. If I have the same problem tomorrow morning I’ll try that.

1 Like

Clearing the ARP cache only helps when the problem presents itself. Clearing when the network is functioning fine won’t have any effect on the system at some other time.

So, the way to test if the problem is the ARP cache, is to wait until the morning… and if the system is not fetching web pages… then clear the ARP cache and see if web pages load as expected.

If the problem persists after the ARP cache is cleared, then the problem is not the ARP cache.

Apparently there’s also a DNS Cache which can be viewed and cleared as well…

My guess is that one of these two is your problem.

There are a few things you can test if the problem persists:

  • set a lower lease time on the router
  • clear DNS cache with ipconfig /flushdns
  • set Google DNS servers and
  • reset NIC on Windows 10

Keeps us in touch :wink:

Cleared the DNS cache. Going to leave it at this for now, since I see little point in trying everything at this point. If I try everything I’ll never know where my problem actually resides. Thank you again for the suggestions.


This happened to me while using a ISP called Vodafone. They limit the amount of simultaneous connections to a very low number. So when you hit that number, internet seems to be stalling, and after a few seconds-minute it will go back to normal, if the number of connections have gone down. If the number of active connections are still the same, problem will persist.
If for example, there are 4 pcs connected to same router, and 4 mobil phones, and the tv, and a gaming console, and are all using internet at same time, you will have this connection stalling problem most surely.

Cant say it is your problem, but it is surely a posibility.

Storj has a option in config.yaml file:
line 176: storage2.max-concurrent-requests: 0

and it is by default 0, you should limit it to 2 and see what happens.

Although this parameter is commented out in the config file, so I am not sure it is a working parameter.

Always restart your Storj Node Service after making changes to the config.yaml file, so changes take effect.

Take much caution when editing config.yaml file since you can break things, make a backup or two, of that file before editing it

Woke up this morning and everything is working fine. So at this point it seems like it might have been have been the DNS cache. Thanks to all for the suggestions. I believe this was happening every(?) morning so all seems good at this point.


Please, comment out this line. It should not be set.