HDD full but 1.9TB free

Hey Guys,

i run at home one node in VMware Workstation pro, with a 4TB hard disk.
My Docker run command i start with storage.allocated-disk-space=3.5TB
VMware is configured with a max drive size of 3.5TB - VMware says 1.5TB is used and 2.2TB is free.
On my node webinterface :14002 the following : Disk Space Remaining 1.94TB
Storj exporter with Prometheus says 1.6TB used but this value is nailed. My node think its full Oo - im on the newest version 1.01 and all my another nodes running smooth, with a lot of more space available.

Where do you enter it?

In the command to run the docker would be:
-e STORAGE = “3.5TB”

Can’t see anything wrong from what you shared… aside from…

https://documentation.storj.io/setup/cli/storage-node
^

How much disk space you want to allocate to the Storj network

Be sure not to over-allocate space! Allow at least 10% extra for overhead. If you over-allocate space, you may corrupt your database when the system attempts to store pieces when no more physical space is actually available on your drive. The minimum storage shared requirement is 500 GB , which means you need a disk of at least 550 GB total size to allow for the 10% overhead.

Going to need to see some logs or error messages to tell whats going on…

-e STORAGE=“3.5TB” is in my docker run command. i checked… in htop it is storage.allocated-disk-space=3.5TB written

where i can check my logs? - sorry im a docker noob =D

Your logs is inside the docker container…
personally i run, to export the logs.

docker logs storagenode >& /zPool/storj_etc/storj_logs/2020-04-07_storagenode.log

/zPool/storj_etc/storj_logs/2020-04-07_storagenode.log is my path for saving the log

This means your maximum allocated storagenode space should be 90% of that…
so MAX

-e STORAGE=“3.15TB"

okay change the start command. my logs from 2020-04-07 are without any errors.

but i see, that the available space not listen and i only downloads have:
the last few days only downloads and nothing to upload although the node is full O.o

before:

“Piece ID”: “HUGLAIQHQV27XXIV7G3FSAR4KQNNQOH4SNX7KQN7XWF7YUY6XSHQ”, “Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “Action”: “PUT”, “Available Space”: 269973427456}

2020-03-31T11:10:02.495Z INFO piecestore uploaded {“Piece ID”: “HUGLAIQHQV27XXIV7G3FSAR4KQNNQOH4SNX7KQN7XWF7YUY6XSHQ”, “Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “Action”: “PUT”}

now:

|2020-04-07T22:33:45.338Z|INFO|piecestore|download started|{“Piece ID”: “C33EIX56WLRBGFXLDBPFIEH6EWA5YQ6JGJEU7XQLZ4LAQ5FUR3TA”, “Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “Action”: “GET”}|

|2020-04-07T22:33:47.813Z|INFO|piecestore|downloaded|{“Piece ID”: “C33EIX56WLRBGFXLDBPFIEH6EWA5YQ6JGJEU7XQLZ4LAQ5FUR3TA”, “Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “Action”: “GET”}|

Perhaps you confused with wording. All wording from the customer’s point of view: download from the network, i.e. egress from your node; upload to the network, i.e. ingress to your node.

This slove not my problem. but in this point you right. i twisted in logs down, and upload. That explains the “available space” in the upload progress… So it may be that no data is currently being uploaded to Europe, and that is the reason why my space is nailed on 1.6TB since four days?

Unfortunately, there is no predictable usage. It could be like this days, weeks, until customers want to upload something to the network and your node will be closest to them.

okay. i have a look in the next days. Thanks !