Help configuring portmap.io

it’s my first attempt at setting up a storj node.
my ISP uses GC-Nat so I tried to use portmap.io to be able to open port 28967. the problem I have now is that I already download the open vpn settings in addition to putting the portmap.io host in config.yaml along with the port and my node is marked as offline. what am I doing wrong?

it doesn’t matter anymore, I solved it

the data marked with the arrows are exactly what you have to use to configure the node,

the second port you have to enter the one that gives you storj

3 Likes

I’m trying to get this set up too. My config on portmap.io does not use those settings you indicated with arrows, in fact, it has given a different port number, is that right?

mine has 40769 as the port on portmap

Any idea how much lower is youre ingress vs having a dedicated ip? Not shared with other peoples nodes?

Check the following link to see if your node is on the same /24 subnet as another. But yes, the ingress is effectively split evenly between the nodes in the same subnet.

Thanks :slight_smile: just found out there are over 16 nodes on that subnet… So it should take ages just to get vetted…

Yes, the port and hostname will be different. Just use this port and hostname as your external address and port in the the ADDRESS parameter (docker) or contact.external-address: in the "C:\Program Files\Storj\Storage Node\config.yaml" (Windows GUI).

Ouch…
And how many are yours amongst them?!

The only way to counter balance that would be to have many nodes yourself…
Or change subnet, if possible.

Thank you for the tip, I’ll have a go at configuring it.

Edit:

I got my first node on my machine to work, but the second node on the same machine can’t seem to connect. They are both using the same ADDRESS parameter in docker.

node 1 (This one works)
docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 14002:14002
-e WALLET=“LONG NUMBER WAS HERE”
-e EMAIL=“EMAIL WAS HERE”
-e ADDRESS=“USERNAMEREMOVED-34882.portmap.host:34882”
-e STORAGE=“1800GB”
–mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode-penknife",destination=/app/identity
–mount type=bind,source="/mnt/penknife",destination=/app/config
–name storagenode-penknife storjlabs/storagenode:latest

node 2 (This one is offline)
docker run -d --restart unless-stopped --stop-timeout 300
-p 28968:28967
-p 14003:14002
-e WALLET=“LONG NUMBER WAS HERE”
-e EMAIL=“EMAIL WAS HERE”
-e ADDRESS=“USERNAMEREMOVED-34882.portmap.host:34882”
-e STORAGE=“1800GB”
–mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode-eneloop",destination=/app/identity
–mount type=bind,source="/mnt/eneloop",destination=/app/config
–name storagenode-eneloop storjlabs/storagenode:latest