Help: server rpc error in log print

Hi Help,

My ARM64 node has run since mid July, it worked well for only first week with 40+ GB data storage. Starting from late July there was no any inputs/outputs, at that time log output sth. like vetting process incomplete, and I noticed a similar post in which the reporter was recommended to wait for one month to see whether the node would be recovered.

There was zero data in Aug and now it takes more than one month, there is still no data inputs/outputs, today I have just restarted the node with below command (proven working since original set-up)

Now there is error message like “server rpc error”, any idea?


docker run -d --restart unless-stopped -p 4511:28967 \
    -e WALLET="0x537eB99Acda********************" \
    -e EMAIL="larry.****@******.com" \
    -e ADDRESS="" \   (#I have fixed public IP address )
    -e BANDWIDTH=20TB \
    -e STORAGE=6TB \
    --mount type=bind,source="/home/cc/.local/share/storj/identity/storagenode",destination=/app/identity \
    --mount type=bind,source="/mnt/myhdd/storjv3",destination=/app/config \
    --name storagenode storjlabs/storagenode:arm
root@cc_0394:/mnt/myhdd# uname -i
root@cc_0394:/mnt/myhdd# docker logs --tail 50 storagenode
2019-09-02T08:15:47.592Z        INFO    Configuration loaded from: /app/config/config.yaml
2019-09-02T08:15:47.599Z        INFO    Operator email: larry.*****@*******.com
2019-09-02T08:15:47.600Z        INFO    operator wallet: 0x537eB99Acda************************
2019-09-02T08:15:53.809Z        INFO    version running on version v0.19.5
2019-09-02T08:15:53.897Z        INFO    db.migration    Latest Version  {"version": 18}
2019-09-02T08:15:53.910Z        INFO    bandwidth       Performing bandwidth usage rollups
2019-09-02T08:15:53.913Z        INFO    Node 1fd6nap2vJHk7yUCeSULKYtdrsKSaJvd7s6LEDQjDLexUNRL5z started
2019-09-02T08:15:53.914Z        INFO    Public server started on [::]:28967
2019-09-02T08:15:53.915Z        INFO    Private server started on
2019-09-02T08:15:53.947Z        INFO    piecestore:monitor      Remaining Bandwidth     {"bytes": 20000000000000}
2019-09-02T08:15:54.133Z        INFO    version running on version v0.19.5
2019-09-02T08:16:28.771Z        ERROR   server  rpc error: code = PermissionDenied desc = untrusted peer 1QzDKGHDeyuRxbvZhcwHU3syxTYtU1jHy5duAKuPxja3XC8ttk

Storage Node Dashboard ( Node Version: v0.19.5 )


ID           1fd6nap2vJHk7yUCeSULKYtdrsKSaJvd7s6LEDQjDLexUNRL5z
Last Contact 0s ago
Uptime       3h17m37s

                   Available        Used     Egress     Ingress
     Bandwidth       20.0 TB         0 B        0 B         0 B (since Sep 1)
          Disk        6.0 TB     32.7 GB


Neighborhood Size 150

I got the same untrusted peer 1QzDKGHDeyuRxbvZhcwHU3syxTYtU1jHy5duAKuPxja3XC8ttk

my post:

and I still have the same response:

Error Codes: What they mean and Severity Level [READ FIRST]

It is explained already!


Ok I woke up properly and I got it! :sweat_smile:


Got it, and yes it sounds explained.


4 posts were split to a new topic: API dashboard. curl: (52) Empty reply from server