How do I start the node again I failed to install for the first time

How do I start the node again I failed to install for the first time when I tried to introduce the identity key on Powershell gave me error all the time

Hello @Danielolteanu-uk ,
Welcome to the forum!

Delete a previous identity and data and start from scratch: Introduction - Node Operator
If you would meet difficulties - please, ask here on the forum and our friendly Community will help you.

The node was disqualified now do I request a new identity token? I have to request it with different email address as I tried to request it again and gave me the same one.

You need a new identity. And you need to remove all old data.
You can use the same email for auth token request.


I started the process again I requested a new token with a different email because the token requested was the same. I put the inbound rule on Powershell I downloaded the Binnary identity I run they keys and introduce the identity token however keep giving me 1 and 2 after verify it mean that the identity wasn’t created why’s that I still didn’t manage to install the node. I verify with my Internet provider I have a fix ip and I made the port forwarding on 28967 but still something went wrong and I don’t know what’s it is. Any help please
I did forwarded the port I introduced the internal IP and I did double check with my Internet provider who assisted me however I still have a problem and I don’t know how to look for it

You need the identity to be 2 and 3, otherwise it won’t work. There’s no point moving past that point until the identity is correct.

I don’t understand what I’m doing wrong?

I mean I made the port forwarding and I think is correct first I checked that my external ip is the same as in the commands then I made the port forwarding in my rooter with the ipv that I traced I put the port range correctly I made the inbond rule on Powershell I downloaded the Binnary identity I got all 36 difficulty then when I paste the authorisation token still gave me 1/2 I don’t understand what I’m doing wrong

Ignore the port forwarding for now. You need to resolve the identity authorisation first.

The picture you posted suggest the command is not run correctly. Please show the results of these commands - Identity - Node Operator

I got the authorisation token now I used a new PowerShell version and it was ok this time however I’m having hard times with port forwarding my friends scratch their heads too I mean I got the inbound rule set it I put all for outbound however shows me that I’m still offline

Can you use PrtScr button on your keyboard instead of photo from smartphone?
I would assume that this is a piece of screen with port forwarding rule.
You do not need to specify all these ports, you need only 28967.
What is hided behind “Default”?
What the checkbox “Enable” will enable?

It says enable -Configure originating IP ? No idea what’s this . Anyway Im having hard times making this node working but I dont want to give up after I spent so many days with I made the identity gave me 2 and 3 and save it however I dont know if Im doing he last bit right

In this rule:

  • start port: 28967
  • end port: 28967
  • Translation start port: 28967
  • Translation end port: 28967

The WAN interface - please, select connection with Internet (maybe “default” is a right one).

The IP should be the same as IP of your device with storagenode.
The originating IP is not needed, so leave it as is (not enabled).
If identity check returns 2 and 3, the identity should be ok.

Still offline I know for sure I have a static ip I pay for it I have no idea how to do this I might put the wrong ip I put the ipv that I retrieved with the second command and I put as well as a firewall rule too 2021-04-21 (3)|690x387 IMG_20210421_230800|666x500

I’m online now finally the node is operational

Maybe you can share your solution so other can benefit from it. That’s the point of this community.

Sure the whole point is making sure you have the adequate tools I was struggling for more than a week to install the node and making the node running I couldn’t make the identity correctly as always the commands gave me 1-2 instead of 2-3. I installed Powershell ISE you can find it on Github. So I managed actually to pass all the commands correctly.
Second issue is coming with port forwarding thank you Alexey for great support however the confusion is
1.When you portforwarding we easily confuse our static ip, gateway and ip what we need to know is the gateway is not important if you know how to get to your rooter, ip4 is necessary for portforwarding in your rooter on mine I put it as Default and if some rooters asking you for port range or originating port - transition port - end port etc as my rooter did then put the same value for all.
Best to pass the firewall rule on Powershell rather than manually
Is important to delete all data including the firewal rules if you had failed attempts and I install and uninstall the node several times and I have to clean previous versions from Downloads too.
Important after port forwarding when you install the node the most confusion comes when asking you for the external ip which is actually your static ip :28967 is not with the same ip you just port forward is the ip of your pc. Mine I have it requested from my internal provider and is best if you can request it too
Now the node is actually running and if you do this right you’ll see the node online straight away. If is not online just uninstall and delete previous data all data from folders, program files, windows etc and restart again
Some you tube tutorials are actually really bad as I was making the same error with a guy that actually he installed the node first therefore you don’t have to put the firewall rule first and is best to use Ctrl+C and Ctrl+V when you paste the rules on Powershell
I hope this will help

1 Like