How I fixed my Windoze node stuck at 1.25.2

[23:15:01] -Non-ICE- why is my windows node still on 1.25.2?
[02:16:59] -brimstone- oof, you should be on 1.31.2
[02:17:11] -brimstone- manually update it Non-ICE?
[02:17:23] -brimstone- it’s probably DQed already though
[18:01:41] -Non-ICE- why does it not say its DQ’d then?
[18:07:58] -Non-ICE- all my nodes are 100% suspension
[18:08:12] -Non-ICE- whatever that means…
[18:08:50] -Non-ICE- they are all ALSO 100% Audit
[18:09:07] -Non-ICE- and online.
[18:19:39] -Non-ICE- 2021/06/14 18:18:10 downloading versions from
[18:19:39] -Non-ICE- 2021/06/14 18:18:10 invalid character ‘p’ after top-level value
[18:19:51] -Non-ICE- wat?
[18:20:33] -Non-ICE- 2021/03/25 11:40:36 downloading versions from
[18:20:33] -Non-ICE- 2021/03/25 11:40:36 storage node version is up to date
[18:20:33] -Non-ICE- 2021/03/25 17:40:35 downloading versions from
[18:20:33] -Non-ICE- 2021/03/25 17:40:37 invalid character ‘p’ after top-level value
[18:20:41] -Non-ICE- this why so many nodes broke???
[18:22:14] -Non-ICE- someone fucked something up march 25th
[18:38:56] -Non-ICE- (i didn’t say it wasn’t me)
[18:56:56] -brimstone- maybe!
[18:57:05] -brimstone- if you restart the uploader, does it succeed?
[18:59:01] -Non-ICE- no
[18:59:03] -Non-ICE- same error
[18:59:53] -Non-ICE- i have also whitelisted in pihole and ipconfig /flushdns to no help
[19:03:30] -brimstone- oh wild, there’s no json at
[19:03:47] -Non-ICE- so it wasn’t me :wink:
[19:04:04] -Non-ICE- 404 page not found
[19:04:51] -Non-ICE- ‘p’ is for ‘p’ in ‘page’ ? xD
[19:12:03] -brimstone- probably yes
[19:13:07] -Non-ICE- so how do we alert anyone at storj with this?
[19:13:38] -brimstone- the is the best place, honestly
[19:14:40] -brimstone- try downloading the updated one and installing it?
[19:14:43] -brimstone- the updated updater
[19:14:48] -brimstone- maybe it’s a known bug?
[19:18:11] -Non-ICE- erhm, i replaces the storagenode-updater.exe and now the service will not start
[19:18:16] -Non-ICE- replaced’
[19:19:13] -Non-ICE- is there an installer for the updater service?
[19:20:10] -brimstone- is that not the installer? herm
[19:20:14] -brimstone- not sure where the installer is then
[19:20:26] -brimstone- if that’s just a binary, you should be able to just replace the one on disk
[19:20:37] -brimstone- but obviously it doesn’t
[19:20:39] -Non-ICE- the zip file only contained storagenode-updater.exe and it claims to be a cli tool
[19:37:21] -Non-ICE- the new updater is not happy
[19:37:50] -Non-ICE- and the old one does not support any commands
[19:38:26] -Non-ICE- anyway i e-mailed Shawn
[19:49:57] -brimstone- i hope you get a response
[19:52:49] -Non-ICE- Disqualified - audit 59% on eu1, but i think he got all the files
[19:53:49] -Non-ICE- this is a ‘Big OOF!’ moment for storj it appears…
[19:56:15] -Non-ICE- 1 of 4 nodes still not updated to 1.26.3 - #2 by SGC
[19:58:07] -Non-ICE- any other ways of fixing the updaterservice? google is not helping
[19:59:39] -brimstone- not from me, maybe elsewhere in the forums
[20:17:19] -Non-ICE- uhm… trying to find the updater from the next version, could be 1.26.3
[20:17:26] -Non-ICE- might solve things
[20:20:11] -Non-ICE- D:\storjapp-storagenode-updater.exe run --config-dir d:\storjapp
[20:20:11] -Non-ICE- 2021-06-14T20:19:46.071+0200 INFO Configuration loaded {“Location”: “d:\storjapp\config.yaml”}
[20:20:11] -Non-ICE- 2021-06-14T20:19:46.119+0200 INFO Invalid configuration file value for key {“Key”: “log.caller”}
[20:20:11] -Non-ICE- 2021-06-14T20:19:46.121+0200 INFO Invalid configuration file value for key {“Key”: “log.encoding”}
[20:20:11] -Non-ICE- 2021-06-14T20:19:46.127+0200 INFO Invalid configuration file value for key {“Key”: “log.level”}
[20:20:11] -Non-ICE- 2021-06-14T20:19:46.127+0200 INFO Invalid configuration file value for key {“Key”: “log.stack”}
[20:20:11] -Non-ICE- 2021-06-14T20:19:46.130+0200 FATAL Unable to find storage node executable binary.
[20:20:11] -Non-ICE- D:\storjapp-
[20:20:14] -Non-ICE- meh
[20:21:33] -Non-ICE- hmmm, my storjnode.log is 11GB
[20:21:47] -Non-ICE- notepad.exe refused xD
[20:21:53] -brimstone- lol
[20:23:48] -Non-ICE- getting closer:
[20:23:49] -Non-ICE- D:\storjapp-storagenode-updater.exe run --config-dir d:\storjapp --identity-dir D:\storjapp\Identity\storagenode
[20:23:49] -Non-ICE- 2021-06-14T20:23:27.495+0200 INFO Configuration loaded {“Location”: “d:\storjapp\config.yaml”}
[20:23:49] -Non-ICE- 2021-06-14T20:23:27.543+0200 INFO Invalid configuration file value for key {“Key”: “log.stack”}
[20:23:49] -Non-ICE- 2021-06-14T20:23:27.546+0200 FATAL Unable to find storage node executable binary.
[20:23:49] -Non-ICE- D:\storjapp-
[20:24:33] -Non-ICE- why is it not finding the storagenode binary?
[20:24:44] -Non-ICE- and why is there no command to set the path?
[20:24:55] -Non-ICE- the path should be in the confing yaml
[20:26:24] -Non-ICE- ehm, which its not
[20:29:22] -Non-ICE- holy moly!
[20:29:52] -Non-ICE- D:\storjapp-storagenode-updater.exe run --config-dir d:\storjapp --identity-dir D:\storjapp\Identity\storagenode --binary-location d:\storjapp\storagenode.exe
[20:35:23] -Non-ICE- nope
[20:35:31] -Non-ICE- my updater is stuck
[20:36:56] -Non-ICE- nevermind xD
[20:36:56] -Non-ICE- VERSION
[20:36:56] -Non-ICE- v1.31.2
[20:37:04] -Non-ICE- i frikking fixed it
[20:37:42] -Non-ICE- worked when i ran the above line using 1.26.3 updater with admin rights
[20:39:53] -Non-ICE- but my update service is broken
[20:39:56] -Non-ICE- still
[20:39:59] -Non-ICE- bah
[20:40:26] -Non-ICE- “storagenode-updater.exe run --config-dir d:\storjapp --identity-dir D:\storjapp\Identity\storagenode --binary-location d:\storjapp\storagenode.exe”
[20:45:33] -Non-ICE- and now its hacked and working
[20:45:58] -Non-ICE- sc config “storagenode-updater” binPath="d:\storjapp\storagenode-updater.exe run --config-dir d:\storjapp --identity-dir D:\storjapp\Identity\storagenode --binary-location d:\storjapp\storagenode.exe"
[20:46:03] -Non-ICE- [SC] ChangeServiceConfig SUCCESS
[20:46:03] -Non-ICE- C:\WINDOWS\system32-
[20:46:17] -Non-ICE- until it brakes next time


generally the storagenode software and the identity and the data are three seperate entities essentially…

ofc a bit more complex than that, but basically… do tho i’m very unfamiliar with the current workings of the windows node software, then you should be able to take the data and identity out, reinstall the software and then put the identity and data in place in a newly installed software.

it’s done that way to make it easy to maintain long term.
because one can fully replace the software with ease.

Basicly I just nudged the auto-updater back into a working state.

1 Like