How to disable payments by zksync?

Hello, my last payments have been made through zksync, the problem is that I don’t know why that happens.
Could it be that I have inadvertently activated that payment method?
If so, how can I see if it is effective? can i go back?

Is STORJ only paying through zksync?

I hope you can answer me
Thank you!

If you have opted into zkSync, somewhere you have set your “wallet_features” setting to be zksync. The easiest way to deal with this is remove zksync from your wallet_features and you will no longer get layer 2 payments.

That said, even if you aren’t opted into layer 2, Storj uses zkSync withdrawal to pay layer 1 payments for all layer 1 payments. In this case you are receiving payment over layer 1, even though the source address is the zkSync contract. I don’t believe there is anything to change here. Is this what you mean?

3 Likes

Thanks for your answer, but what is “wallet_features”? is the command line with which the system starts?

Yes, if you have configured it then “wallet-features” is either in the docker run command or in the config.yaml file.

If you can see your storj token balance on https://etherscan.io/ then you have normal L1 payments, but as @jtolio says:

Storj uses zkSync withdrawal to pay layer 1 payments

I checked my configuration and I don’t have payment enabled through zksync, but when I see through https://etherscan.io/ I see what is in the image.

Are the last 4 payments coming from the zksync network? but they are not payments that are in that network. Is that correct?

If so, why don’t I see that balance in my wallet? (coinomi)

The payments come from the zksync contract. The contract interacts with the zksync network to complete the payments.

It doesn’t look like coinomi supports storj tokens by default - Supported assets | Coinomi - so you need to add the token manually in your wallet.

I have been using coinomi for years and I have no problem seeing and using my storj tokens.
The last payment that is seen in my wallet is from January 2022, after the following payments, which apparently come from zksync, I cannot see them in my storj toke, but I do see that there are transactions from my ETH wallet. I’m a bit confused, could it be that coinomi is not compatible with zksync?

These are usual transactions on L1. I think you need to file a support ticket to Coinomi. But maybe they do not support transactions from smart contracts (this is unusual though and looks like a bug in their software).
Is your balance in Coinomi matching the balance on Etherscan?

1 Like

With Coinomi you hold your own seed phrase and it allows you to export your private keys. So you should be able to access your funds by importing the private key/seed phrase to a different wallet that would allow you to access tokens you received via L2 → L1 zkSync withdrawal, in case you cannot resolve the issue with Coinomi.

1 Like

+1 contact Coinomi support
They’ve been quickly responsive in the past.

I’ve had similar issues with their wallets not showing deposits or balances correctly.
Support helped me figure out it was a combination of their software issues + older/no longer compatible operating system versions.

As @heunland said, try importing the whole wallet to another , freshly updated, device.
Hope you get it solved soon!