How To Forget Untrusted Satellites

I’m starting to receive e-mail notifications that my nodes are offline on these retired satellites…

Your Storage Node on the US2 satellite has gone offline
Your Storage Node on the Europe-North-1 satellite has gone offline

This seems unneeded, if not confusing!

EDIT - See:


I try to forget a very old stefan satellite, and it does not work on it.
I still get constant log about it every 2 minutes.

WARN    console:service unable to get Satellite URL     {"process": "storagenode", "Satellite ID": "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW", "error": "console: trust: satellite \"118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW\" is untrusted", "errorVerbose": "console: trust: satellite \"118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW\" is untrusted\n\*Pool).getInfo:252\n\*Pool).GetNodeURL:187\n\*Service).GetDashboardData:188\n\*StorageNode).StorageNode:45\n\tnet/http.HandlerFunc.ServeHTTP:2122\n\*Router).ServeHTTP:210\n\tnet/http.serverHandler.ServeHTTP:2936\n\tnet/http.(*conn).serve:1995"}

It works for the other 2 new decommed satellite


Then forgetting it seems to work

Thank you for providing a GUI example.

It is difficult to believe that none of the programmers at Storj have the skill to actually write a script to remove old satellites automatically when they push an update.

Please submit a PR - our team is always glad to accept a Community contribution!

1 Like

Same here. I had run the forget-satellites command before toda and still received the offline notification today morning. Seems like a minor bug there.

For me I’m getting an error in GUI version: argument --force not accepted, what am I doing wrong?

Поставьте оператор - &, так же как в примере.


Use the operator - &, just like in the example.


Ah okay, I forget to execute the storagenode.exe - now it did work!
I typed just storagenode without exe

If we have more than one windows gui node on PC do we need to mension --server.private-address command in forget node procedure?

I try to make it one button click in my toolbox but getting error
command is RunCommandCom(“”“C:\Program Files\Storj\Storage Node\storagenode.exe”“”, "forget-satellite --all-untrusted --identity-dir " & Iden & " --config-dir " & conf & " --server.private-address " & PrivateAdd, True)

but getting error
2023-10-11T14:07:56+03:00 INFO Anonymized tracing enabled {“process”: “storagenode”}
Error: cannot specify both satellite IDs and --all-untrusted
I get it even if i make it in CMD
C:\Program Files\Storj\Storage Node>storagenode.exe forget-satellite --all-untrusted --identity-dir C:\Identity\storagenode\ --config-dir C:\Program Files\Storj\Storage Node\
2023-10-11T14:18:04+03:00 INFO Anonymized tracing enabled {“process”: “storagenode”}
Error: cannot specify both satellite IDs and --all-untrusted

@clement can you watch why this error happens?

@Vadim Could you try placing quotation marks around the path containing spaces in your command?

storagenode.exe forget-satellite --all-untrusted --identity-dir C:\Identity\storagenode\ --config-dir "C:\Program Files\Storj\Storage Node\"

thank you now i found that it shold work like this
storagenode.exe forget-satellite --all-untrusted --identity-dir C:\Identity\storagenode --config-dir “C:\Program Files\Storj\Storage Node” and cmd should run as administrator

Update: but it not working, it looks like do nothing. or it happen in background for some day?
I mean folder delete process.

As I have lot of win gui nodes in one pc I tried also
C:\Program Files\Storj\Storage Node>storagenode.exe forget-satellite --all-untrusted --identity-dir C:\Identity4\storagenode --config-dir “C:\Program Files\Storj4\Storage Node” --server.private-address

but result is the same.

You need to have quotes around paths and paths to the folder should end with \\, i.e.

storagenode.exe forget-satellite --all-untrusted --identity-dir "C:\Identity\storagenode\\" --config-dir "C:\Program Files\Storj\Storage Node\\"

You also should not specify a satellites IDs if you use--all-untrusted, and you need to have satellitesIDs with hostname and port in the node’s config

likely yes, and you need to use the same private address from the node’s config. If it’s specified as, you should use it in this command.

result like the same, just nothing

If I have DBs in not standard location do i need mansion it also somehow?

It will not print anything, if the command is succeed.

no. I think than even providing a private address should not be the case, but well, we have the similar problem with graceful exit and I do not know, is it fixed or not:

I found some results in logs on info level.

2023-10-12T08:38:25+03:00 INFO Anonymized tracing enabled {process: storagenode}
2023-10-12T08:38:25+03:00 INFO Identity loaded. {process: storagenode, Node ID: 1ige6GogSr21Je5S16J1HJx5zUYEKTCjKGcxWcoCuPwjQc5aCa}
2023-10-12T08:38:25+03:00 INFO No untrusted satellites found. You can add satellites to the exclusions list in the config.yaml file. {process: storagenode}

but this satelites are untrusted by storj, is it work only if i manualy add them?

It works only if they explicitly specified as untrusted in the node config.