I cannot mount drives to Stoj in docker in a proxmox vm. Help!

Hi guys,

most definitely this is my own fault and I am understanding something wrongly. I am running an Ubuntu server VM in Proxmox and on that I am running docker. This VM has two virtual harddrives and I am pretty sure the second one (so the one that is not the system drive) is mounted correctly. I can write fiels to it and read from it from within the vm so that should be fine.
If I am not trying to run the docker Setup script looking something like this:

sudo docker run --rm -e SETUP="true" --mount type=bind,source="/home/felix/ident/Storj/Identity/storagenode",destination=/app/identity --mount type=bind,source="/mnt/storj“,destination=/app/config --name storagenode storjlabs/storagenode:latest

Docker just displays “>” in the next line. As if I was in a docker terminal… on my Raspberry Pis this doesn’t happen and it just runs the setup correctly. This happens every time i give docker any kind of --mount command and I have sadly no clue hot to get this working…

And yes I know running docker using sudo like here is not a good practice. But that surely isnt the cause of my --mount issues, is it?

Thank you for your help :grinning:

Can you make sure you aren’t using any curly quotes ? They should be :arrow_down:

He is right but he means that you should re-type that quote mark.
The > is from your shell, bash?, and it shows that you have an unmatched quote

Oh god! I tried for hours and hours and at some point I started editing the command on google docs and I didn’t notice it replaced the good " with some bad word processing ones… Thank you so so so so much man. Everything works now perfectly. Thats really a stupid mistake to make but I wonder why it would not just also accept the curled ones because i recon this mistake is gonna be made very often.

Again, Thank you very much!