I can't open porton my router

Hi everyone!
I’m trying to set a node on my PC for about a week and thing that i just can’t overcome is port forwarding. I have read posts on multiple forums, checked all port related threads on this forum, called my ISP if maybe there is something blocked but it seems like i’ve done every thing correct.

  1. Added rule for firewall
  2. My public IP shows the same as the IP that my router shows
  3. Set my local IP as the target IP in port forwarding settings

But sites like yougetsignal.com still shows port as closed.
One thing that i suspect as a cause of a problem is that powershell shows storjnode service as stopped and when i put command “Get-Service storagenode” i got this:
Start-Service : Failed to start service ‘Storj V3 Storage Node (storagenode)’.
At line:1 char:1

  • Start-Service storagenode
  •   + CategoryInfo          : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
      + FullyQualifiedErrorId : StartServiceFailed,Microsoft.PowerShell.Commands.StartServiceCommand

And if i understand it correctly there has to be some service running to answer the port check ping.

I’ve completly run out of options and dont know what to do, thanks.

Yes, Storj must be running and listening on your defined port in order for a port to show as open.

Sounds like you have a Windows node, but I don’t have experience using Windows with Storj.

Did you also add a IPv4 TCP port port forwarding rule in you router? This might be the problem.

Your problem is indeed that the Windows service is not running.

Try starting the service manually from the Windows services tab.

I’ve tried to reinstal node before but now i also deleted registry and after reinstall i can finally get into dashboard and seems like everyting is working now. Thanks for help!

1 Like