I can't reinstall the node, installation msi error

Hello all,

I changed computer and wanted to reinstall the node while maintaining the same identity and data.

But the installation failed.


"2020-08-18T14:07:16.708+0200 FATAL Unrecoverable error {“error”: “storage node database error: database info already exists”, “errorVerbose”: “storage node database error: database info already exists\n\tstorj.io/storj/storagenode/storagenodedb.(*DB)”

Can someone help me?
I wouldn’t like to start the 0 node

Thank you.

Welcome to the forum @Tor7!

Delete the folder from “C:\Program Files\Storj” and try reinstalling. Make sure you are executing it as admin.

I’ve done it before.

Searching in this same forum I already tried all the solutions, I even reinstalled windows and it fails again I delete the Storj folder and it fails again

I don’t know what it can be

Thank you for your help.

I delete the folder and with a powershell in admin mode


and get the same error

Just to be sure, are you using the latest .msi from here

I just tried the last version you told me about and it failed again

The first time I set it up it was all right.
Now I wanted to switch machines while keeping the hard drives, but I can’t reinstall

Sorry for my English. I use a translator.

Thanks for the help.

Unfortunately, it seems that the installer expects setting up a new database at the moment. I’m not yet sure whether this is a bug or a missing feature.

However, as a workaround, if you:

  1. disconnect network (to ensure you don’t respond with invalid responses during this process)
  2. install storagenode and for data storage use a different location
  3. ensure that storagenode services (storagenode and storagenode-updater) are stopped (stop them if necessary)
  4. change the path to your actual data location in config… search for storage.path: in config.yaml… this is in the same folder where you installed the binary (usually C:\Program Files\Storj\Storage Node\).
  5. try starting storagenode – this should fail the version check, because there’s no network (however it should be able to open the database)
  6. reconnect the network
  7. start the services (storagenode and storanode-updater)

Thanks! It worked, I got it installed by changing the data path.

But now it has generated another database in the same hard disk, so the disk has run out of space and it didn’t start correctly.

Finally I decided to format the data disk and create the new one.

It’s already working and it’s online.

Thank you very much for your help.

If you deleted data, I think this identity is disqualified already.
Or did you decide to start from scratch with a new identity?

I had to start with another identity.

When performing the steps mentioned above, the program tried to create a new database and as there was no space left in the hard disk (because it was full) it returned to me with the error so I could not reconnect with the original database.

I guess I didn’t do the steps right and I couldn’t fix it

I decided to start from 0 now that I’ve been working for a short time

Thanks for all

We could fix it. But now too late.
The solution was simple: remove the excess databases and edit the path in the config to the right one. Then restart the service

hello could you help me please, is it possible to reinstall storj v3 while keeping my authentication and authorization?
because impossible to start it after a prolonged shutdown I think there is a bug thank you

Yes, it’s possible. But "C:\Program Files\Storj" must be deleted before re-install.
Also, please, post 20 last lines from the log: https://documentation.storj.io/resources/faq/check-logs

Hello, im having the same issue, i just reinstalled windows i moved my files back but some reason it keeps giving me this issue, it puts the files in place, then the GUI stops at starting services.

Well i uninstalled and now reinstalled and im getting this error when starting the service,


You should search for that file under C:\Users\YOURUSERNAME\AppData\Roaming\Storj\Identity\storagenode

How did you get the path shown in your screenshot ?

Hello @codedbymatt ,
Welcome to the forum!

Please, show 20 last lines from the log