I changed ISP and cant get my nodes running

And for your own safety and privacy, delete the public IP from posts.
Add firewall rules for both protocols for all ports.

I have. they all have xxx in them :slight_smile:

I added all the protocols for all ports - as you saw in the image above

So lets do a receck…

  1. Router - disabled malware protections, and DDOS prevention (in Firewalls rules).
  2. Router - Added port forward rules.
  3. Windows - added firewall rules.
  4. Docker run command…
  5. Clear browser cookies.

Post again the docker run commands from all nodes, between 3 backthicks ```
Anonimise WAN IP, wallet and email, replacing all caracters with xxx.
When you modify the docker command, stop storagenode, remove storagenode and then run.

it will not work on docker version without changing a binding port in the config file or with an option.
This command:

will make this node offline forever, because storagenode listening 0.0.0.0:28967/tcp 0.0.0.0:28967/udp inside the container

Please check the firewall rule for 28967 UDP on your Windows machine, there also should be rules for 28968 UDP and 28968 TCP.
Then try to refresh a browser window or restart the service.

This error:

suggests that your docker node seems running with --network host, please check your virtual switch configuration (with Hyper-V Manager ‚Üí Virtual switch Manager), your WSL2 (or Hyper-V VM for docker) should use a virtual switch connected to ‚ÄúInternal network‚ÄĚ


So it looks about right on the virtual switch manager?

Yes. And if you did not use --network host in your docker run command, there should be no conflict of occupied 28967

As seen in the image above i do have a rule in windows for the storj exe. So that whould be for the gui install.
now i also need one for the docker install?
It weird that it worked on the same machine before changing ISP

Well im gonna try to add another rule then.

Skærmbillede 2022-12-02 kl. 09.58.13

So i just created 4 rules. two for 28967 with udp tcp and two for 28968 also
Going to attempt to launch the docker again

1 Like

Usually yes. But you need also a second rule - for UDP.
Perhaps your firewall were disabled, but Windows enabled it back. So it’s better to configure it instead of disabling.

OKAY! so setting the port forward on both windows AND the router has fixed the docker install… So far so good!
Thanks.

now i need to just restart the GUI install and see if it is also ok.

Restarting the GUI also did the trick! awesome - thanks @Alexey

1 Like