I’m unable to install docker

Hello I have a raspberry pi 4b 4gb and I’m having trouble installing docker. I’m following all the steps on their website but I get an error code. I’ll attach an imagine. Any help is greatly appreciated.

Sometimes when you update an OS on rpi4 it will brick the ablity to use or install docker would require an reinstall of the OS less you are very good with linux, Also I would install the server version of ubuntu on the rpi4.
It’s hard to tell if you used the right command to add I see one error you should uninstall docker and try again and make sure you copy and paste all the commands.

You should check out this to setup node instead of using docker.

Dang I had docker once on here but can’t remember now. I don’t want to do a fresh install because I got my identity and what not in order. It’s running raspbian and I copy pasted all the commands so.

Yea but I see errors in your commands already, You should try to make sure to add the correct commands again. You shouldn’t see any errors.

1 Like

What does this command show ?

docker ps -a

docker ps -a
bash: /usr/bin/docker: No such file or directory

i had a problem installing docker on Ubuntu server… found out it was something to do with ipv6 settings.
but i just reverted to using debian and then it ofc worked on the first try… duno if that is your problem… but if you are on ubuntu server then docker doesn’t work by default atleast if you are running it in a container… ofc you aren’t running it in a container…

forget what i said… lol maybe this isn’t relevant at all…
just gave me a lot of headache to figure out the OS was bugging my docker install

Honestly I’m not even sure it’s driving me nuts. I have tried everything, I’m on raspbian any other software suggestions?

What OS are you running? It looks like there was an error adding the docker repo. If you are running vanilla Raspbian, then you may need the 32 bit version instead of the 64 bit version (this depends on how you installed, most historical Raspbian installations are 32 bit). To try the 32 bit version, change [arch=arm64] to [arch=armhf] in your command to add the repository.

Are you able to provide the following output?:

  1. uname -a

Additionally, remove the repository you partially added, and check that everything is up-to-date (and that apt upgrade -y finishes without errors).

I believe the method you used to add docker will put the repo here: /etc/apt/sources.list.d/docker.list. If it is there, double check that it looks something like this:

deb [arch=arm64] https://download.docker.com/linux/debian buster test

As long as there aren’t any other repositories in that file, you can then go ahead and delete it to remove the repository.

I’m running raspbian ARMv71. Honestly I’m such a noob I don’t know how to do that. When I searched for “/etc/apt/sources.list.d/docker.list” it wasn’t there so I presume I deleted already.

Beside docker we also have linux binaries including an updater. You can now run a storage node without having to run docker.

That’s interesting, can you tell me more?

I put a link directly to it.

Awesome but I do not see it.

Was my first post. Just scroll up

Ohhh okay so I have to run ubuntu server instead of Raspbian?

It probably never got added then; if you go the docker route on the Pi, I would follow the instructions from Docker (the company) here: https://docs.docker.com/engine/install/debian/#install-using-the-repository

One thing to note, they say the method that you were using doesn’t work for Raspbian and you need to use their convenience/helper scripts from here. I would also advise making sure none of your prior docker stuff was still around by running apt remove docker-ce*.

I can’t speak to which method is better to use docker or the systemd method, it will likely depend on how you want to run your setup; I am currently running docker, and will likely continue to use the container approach, as I am hoping to eventually try out K8S, but we shall see.

No you can run it without it being ubuntu server

1 Like

Honestly it seems a little to complicated and way beyond my knowledge. Would it be possible to do docker if I changed the OS?

One of the benefits of the Raspberry Pi and similar boards is the ability to swap uSD cards. I suspect something weird is going on with your current install; and would advise, if possible, that you get a second card (so that you don’t loose your current system) and try to start from a fresh install with the OS of your choosing. If it works, you can either move everything to the new system or try to use the knowledge gained to reimplement it on the original uSD card.

Setting up docker should be essentially copy and paste of the Docker provided commands, so likely something got slightly broken somewhere or is depending on something that is causing issues.

Looking back at the first screenshot, I’m seeing several other commands that are throwing errors. It looks like you may have possibly tried to past a script into the console incorrectly? What guide (with link) where you following for this part?

1 Like