Installed for the first time, says restarting container

Try to read the forum found similar things but nothing helped.

root@raspberrypi:/# docker ps -a
5e60fa20e074 storjlabs/storagenode:beta “/entrypoint” 7 hours ago Restarting (1) 7 seconds ago storagenode
c974f7ba7cd5 hello-world “/hello” 7 hours ago Exited (0) 7 hours ago epic_raman
15b230bdb15a storjlabs/watchtower “/watchtower storage…” 8 hours ago Up About a minute watchtower
38d9f418f8f2 hello-world “/hello” 10 hours ago Exited (0) 10 hours ago epic_driscoll

Start command:

docker run -d --restart unless-stopped -p 28967:28967
-e WALLET=“0x************************************”
-e EMAIL=”*********"
-e STORAGE=”1,6TB"
–mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode",destination=/app/identity
–mount type=bind,source="/mnt/storj1",destination=/app/config
–name storagenode storjlabs/storagenode:beta

root@raspberrypi:/Storjid# ls -l /home/pi/.local/share/storj/identity/storagenode
totalt 24
-rwxr-xr-x 1 root root 546 feb 29 23:36 ca.1582998872.cert
-rwxr-xr-x 1 root root 1076 feb 29 23:36 ca.cert
-rwxr-xr-x 1 root root 241 feb 29 23:36 ca.key
-rwxr-xr-x 1 root root 1088 feb 29 23:36 identity.1582998872.cert
-rwxr-xr-x 1 root root 1618 feb 29 23:36 identity.cert
-rwxr-xr-x 1 root root 241 feb 29 23:36 identity.key

root@raspberrypi:/Storjid# ls -la /mnt/storj1/
totalt 32
drwxr-xr-x 3 root root 4096 feb 29 22:57 .
drwxr-xr-x 3 root root 4096 feb 29 23:17 …
-rw------- 1 root root 7096 feb 29 22:57 config.yaml
drwx------ 2 root root 16384 feb 29 22:24 lost+found

root@raspberrypi:/Storjid# df -h
Filsystem Storlek Använt Ledigt Anv% Monterat på
/dev/root 30G 3,2G 25G 12% /
devtmpfs 459M 0 459M 0% /dev
tmpfs 464M 0 464M 0% /dev/shm
tmpfs 464M 6,3M 457M 2% /run
tmpfs 5,0M 4,0K 5,0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
/dev/mmcblk0p1 43M 23M 20M 53% /boot
/dev/sdb1 1,8T 77M 1,7T 1% /mnt/storj1
tmpfs 93M 0 93M 0% /run/user/1000
overlay 30G 3,2G 25G 12% /var/lib/docker/overlay2/49afc39d591e9397155dcf1413e6feb5234e6e813b396ad813a4f8ea34e7eaf5/merged

When I write docker logs storagenode I only gets this back

root@raspberrypi:/Storjid# docker logs --tail 20 storagenode
–db.conn_max_lifetime duration Maximum Database Connection Lifetime, -1ns means the stdlib default (default -1ns)
–db.max_idle_conns int Maximum Amount of Idle Database connections, -1 means the stdlib default (default 20)
–db.max_open_conns int Maximum Amount of Open Database connections, -1 means the stdlib default (default 25)
–debug.addr string address to listen on for debug endpoints (default “”)
–debug.trace-out string If set, a path to write a process trace SVG to
–defaults string determines which set of configuration defaults to use. can either be ‘dev’ or ‘release’ (default “release”)
–identity-dir string main directory for storagenode identity credentials (default “identity”)
–log.caller if true, log function filename and line number
–log.development if true, set logging to development mode
–log.encoding string configures log encoding. can either be ‘console’ or ‘json’ (default “console”)
–log.level Level the minimum log level to log (default info)
–log.output string can be stdout, stderr, or a filename (default “stderr”)
–log.stack if true, log stack traces
–metrics.addr string address to send telemetry to (default “”)
– string application name for telemetry identification (default “storagenode”)
– string application suffix (default “-release”)
–metrics.instance-prefix string instance id prefix
–metrics.interval duration how frequently to send up telemetry (default 1m0s)
–monkit.hw.oomlog string path to log for oom notices (default “/var/log/kern.log”)

Welcome to the forum @t0mmy1234 !

It should be a decimal not comma.

Changed and restarted but don’t work anyway.

Now these containers are active
46af304eb1f1 storjlabs/storagenode:beta “/entrypoint” 4 minutes ago Restarting (1) 31 seconds ago storagenode
15b230bdb15a storjlabs/watchtower “/watchtower storage…” 9 hours ago Up 7 minutes watchtower

last post it was 4, but this probably bus I restarted device.

Do you have DUC installed

what’s that? I’m not so experienced with linux, ill try look it up

Yep i installed that and think everything went good.

Are you using noip? You need to install dynamic update client DUC. In your run comand you use an dns address and not IP address so you have to have DUC installed.

You could do a fast check and enter your wan ip instead of

If you only installed DUC and did nothing else as I think you didnt (im kind of new to Linux to) every time you reboot you have to start the DUC again with /usr/local/bin/noip2

Yep trying, I forgot to start noip2 again as u wrote.
So if I try change my adress in the start command then I need to reboot system again after that right?

ok now changed to my wan ip and the port that I forwarded in my router but don’t work anyway. Btw my hoot adress is not that’s bcs I changed it :slight_smile:

No you dont need to reboot just do
docker stop storagenode
docker rm storagenode
And copy/paste your new run comand.

And in your run im not sure but it looks like your mount is wrong.

should be

Hmm shownnup wrong and cant fix it.
Not One - before mount but 2

Trying that also.

I can ping my hopto adress from another computer in the network so that should be fine right ?

I dont know. Sorry not good at thoose things.
But if you go to noip and check your ddns it should show your wan

Yep it shows my wan.

So should I try just a single - before mount

Ok thats good.
Do you have 2 - before mount or just 1

Ok now I tried it didn’t work with one -

root@raspberrypi:/Storjid# ./start

invalid argument “ount” for “-m, --memory” flag: invalid size: ‘ount’

See ‘docker run --help’.

Ok now I tried it didn’t work with one -

Has to be 2

Try this with your settings and paths

docker run -d --restart always -p 28967:28967
-e WALLET=“0x0000….”
-e EMAIL=""
-e ADDRESS=“externaladdress:28967”
–log-opt max-size=50m \
–log-opt max-file=10
–mount type=bind,source=/home/pi/.local/share/storj/identity/storagenode,destination=/app/identity
–mount type=bind,source=/mnt/storagenode,destination=/app/config
–name storagenode storjlabs/storagenode:beta

1 Like

docker run -d --restart always -p 28967:28967
-e WALLET=“0xE2978f5fB300B0e30b"
-e EMAIL=”t
-e ADDRESS=“m*********”
-e STORAGE=”1.6TB"
-log-opt max-size=50m
–log-opt max-file=10
–mount type=bind,source=/home/pi/.local/share/storj/identity/storagenode,destination=/app/identity
–mount type=bind,source=/mnt/storj1,destination=/app/config
–name storagenode storjlabs/storagenode:beta

this don’t work :stuck_out_tongue:

Is this correct or should it be read write on config .yaml ?

When i ran on a Raspberry all i did was the run cmd nothing else.

Do you have the identity all done with 6 files?