Installed my first node. Does not start

Hi, i installed my first node on ubuntu 20.4.1 lts but i can’t start it. does not start
This is the startup string:

sudo docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p -e WALLET=myaddress -e EMAIL=myemail -e ADDRESS=myaddress:2896) -e STORAGE=“4.00TB” –-mount type=bind,source=/home/jason/backup/storagenode,destination=/app/identity -–mount type=bind,source=/mnt/md0/storj,destination=/app/config -–name storagenode storjlabs/storagenode:beta

after sending the command this is the result:

docker: invalid reference format.

Can someone help me ?


Welcome I would follow the doc to run it copy and paste it.

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-e WALLET=“my address”
-e EMAIL=“myemail”
-e ADDRESS=“myip”
–mount type=bind,source="</home/dim/.local/share/storj/identity/>",destination=/app/identity
–mount type=bind,source="</mnt/md0/storj>",destination=/app/config
–name storagenode storjlabs/storagenode:latest

I corrected some characters (-) but now i get this error:

docker: Error response from daemon: invalid mount config for type “bind”: invalid mount path: ‘</home/max/.local/share/storj/identity/>’ mount path must be absolute

remove < > from the start from both “/home/dim/.local/share/storj/identity/” “/mnt/md0/storj”

I think he left, right?

How many nodes can I activate on the same computer?

Should I see something at this address


This is only to view locally on the same PC you would need to set it to the local IP address to be able to view it on your network.

2) today i tried to restart the service but i get this error:

  1. When I run this command " sudo docker ps -a " the information returned is always the same.

    How can I see if there is activity in the node?

Best regards.

Ok, I solved the problems above. But the node still does not start, it is always restarting, I send the contents of the log file:

2020-09-08T08:15:58.284Z INFO Configuration loaded {“Location”: “/app/config/config.yaml”}
2020-09-08T08:15:58.284Z FATAL Failed to load identity. {“error”: “file or directory not found error: open identity/identity.cert: no such file or directory”, “errorVerbose”: “file or directory not found error: open identity/identity.cert: no such file or directory\n\\n\tmain.cmdRun:141\n\\n\\n\*Command).execute:840\n\*Command).ExecuteC:945\n\*Command).Execute:885\n\\n\\n\tmain.main:330\n\truntime.main:203”}

You need to either authorize your identity or you aren’t pointed to the correct folder for your identity. How many files does your identity folder have?

I think you missed a storagenode folder in the path /home/dim/.local/share/storj/identity/, it should be /home/dim/.local/share/storj/identity/storagenode

Yes indeed. Fixed and problem solved.

Thank you.

I installed everything, but when i run the command to start docker i get this error:
docker: invalid reference format.
See ‘docker run --help’.

I don’t know what to do, I can’t understand where the problem is.

Best regards.

Think you already posted about this here Installed my first node. Does not start

Do you still have issues with docker run command?

Grazie Alexy,
I solved the previous problem and the node now works. Now I have prepared a second node this time on Raspberry 4, I have done the same things as the previous installation (obviously changing the software version, ie for ARM64) but when I try to start it I get an error: docker: invalid reference format.
See ‘docker run --help’

The issue is still the same - either a wrong paths, or/and curly quotes instead of straight ones (") or/and hyphens instead of double dashes (--) or/and missed back slashes at the end of the line (except the last one).
Please, post your current docker run command between two lines with three backticks ``` (three on the line before the command and three on the line after the command, this will pretty format your command here on forum). You can remove personal information.

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28201:28968 \
    -p 14201:14001 \
    -e WALLET="MyAddress" \
    -e EMAIL="MyEmail" \
    -e ADDRESS="MyPubblicIp:28201" \
    -e STORAGE="500GB" \
    --mount type=bind,source="/mnt/usb/storj/identity/",destination=/app/identity \
    --mount type=bind,source="/mnt/usb/storj",destination=/app/config \
    --name storagenode storjlabs/storagenode:arm


$ sudo docker exec -it storagenode /app/
Error response from daemon: Container ab2b7fd383c8685ec9545a3c8777ada28370cd040e941a0e56a5f02c1e7698da is restarting, wait until the container is running