Is it possible to run 2 docker node on one pc and how is it done

is it possible to run 2 docker node on one pc and how is it done

1 Like

I can’t pull a second docker image for the second node on Mac OS docker run -d --restart unless-stopped -p 28967:28967 -p
-e WALLET=“0x1a526eCA0C55ce1D65189546779481eA6ec67f49”
-e EMAIL=""
-e STORAGE=“1.8TB”
–mount type=bind,source="/Users/neo/Library/Application Support/Storj/Identity/storagenode2",destination=/app/identity
–mount type=bind,source="/Volumes/v2_storj",destination=/app/config
–name storagenode storjlabs/storagenode:latest this is my docker run command

You only need one docker installation per host (machine)

I think these two values are wrong:

-p 28967:28967 -p

The first port must be unique to each node, the second port is the common port for all nodes (28967)
14003 for the second node, 14002 as the common port:

-p 28968:28967 -p

I have 2 node 8.5 TB on 2 pc windows and Mac os and both are full of data

You’re going to have to give us a more complete picture of your situation if you want help. That means, describe which nodes you have and how you’ve set up the ports and forwarding for those nodes. Then describe what you are trying to add.

And this really should be a separate topic as it has nothing to do with the one you posted on.
In the mean time, this post might help: Setting up second machine with storj on same network

okay @BrightSilence at the moment one windows node gui 5TB full of data and one Mac OS docker node 3.5 TB also full of data both behind the same public IP. I want to establish a second docker node on the Mac I have already created the the second identity and have authorized it, the problem that I have encountered is not being able to pull a second docker image from the storjlabs, so when I run the second docker run command I get a container conflict error message. hope I have been more specific than the original post thanks,

Ok, both containers would use the same docker image. You don’t have to pull it twice. I’m guessing you get a naming conflict on the container name? In the future, please post the exact error message so I don’t have to guess.

You can just give the new container a different name. Like the last line in this example:

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28969:28967 \
    -p \
    -e EMAIL="" \
    -e ADDRESS="" \
    -e STORAGE="2TB" \
    --mount type=bind,source="<identity-dir>",destination=/app/identity \
    --mount type=bind,source="<storage-dir>",destination=/app/config \
    --name storagenode2 storjlabs/storagenode:latest

No 2 nodes can use the same external port. Since you’re already running 2 nodes, I assume the ports 28967 and 28968 are already in use, so I used 28969 for this example. You already have a dashboard on this system running on port 14002, so I used 14003 for this one. For more on which ports to use and how to set it up, please refer to the post I linked in my previous post.

One last note, I noticed the command you posted is missing the --stop-timeout 300. This is especially essential on MacOS and Windows docker nodes, as hard killing your node can easily lead to db corruption. Please make sure you add it to both docker nodes.

1 Like

thanks the second container started and it is receiving repair uploads only so thank you. I am adding it now --stop-timeout 300

1 Like

I have a problem with second node shows offline you get signal shows port is open both cli and web dashboard offline here are the logsJesuss-Mac-Pro:~ neo$ docker logs storagenode2 --follow
2020-07-02T15:13:25.445Z INFO Configuration loaded {“Location”: “/app/config/config.yaml”}
2020-07-02T15:13:25.468Z INFO Operator email {“Address”: “”}
2020-07-02T15:13:25.468Z INFO Operator wallet {“Address”: “0x1a526eCA0C55ce1D65189546779481eA6ec67f49”}
2020-07-02T15:13:25.974Z INFO Telemetry enabled
2020-07-02T15:13:26.070Z INFO db.migration Database Version {“version”: 42}
2020-07-02T15:13:26.703Z INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2020-07-02T15:13:27.377Z INFO preflight:localtime local system clock is in sync with trusted satellites’ system clock.
2020-07-02T15:13:27.378Z INFO bandwidth Performing bandwidth usage rollups
2020-07-02T15:13:27.379Z INFO Node 1LSG6b5u9W8PktZ5uu35qSqJWQxoHaafr4CYx6FUY3jgmfCZH6 started
2020-07-02T15:13:27.379Z INFO Public server started on [::]:5000
2020-07-02T15:13:27.379Z INFO Private server started on
2020-07-02T15:13:27.380Z INFO trust Scheduling next refresh {“after”: “8h45m8.395085401s”}fixed it

If you don’t want to get spam, you should remove your email address from that post. Perhaps wallet as well.

Could you show your run command for both nodes and tell us what port the node on the other machine is using? Again please remove email address and wallet. You can remove the address as well, but please leave the port visible.

solved it by stoped removed renamed config restarted problem solved

1 Like