Libuplink 1.0 Release Candidate announced

We are pleased to announce Libuplink 1.0 Release Candidate. Libuplink 1.0 is the new Go API for accessing the Storj network that we are going to support long-term with the Production release of Tardigrade.

The new libuplink is available in a new separate repository under the Apache 2.0 license:

The API documentation is available at

Note that the current release is still a Release Candidate. We are still working on finding and fixing bugs, as well as improving the documentation.

If you have an existing application or language binding based on libuplink 0.x, now it is a good time to try migrating it to the new API and let us know of any feedback you might have. Feedback is welcome here in this topic, or by creating a new issue in the Github repository:

We already migrated our S3 Gateway to use the new libuplink 1.0 API. The G3 Gateway 1.0 Release Candidate is available at this repository:

We are working on migrating also the Uplink CLI and the bindings for C, Android and other languages.


The release is nice but the documentation linked in the gateway is not updated and there are no pre-built releases.
I don’t really want to go through building those from source, especially without a documentation about it.

Btw: Is the nextcloud upload bug fixed?

Documentation is being worked on as we speak. Please ask questions about Nextcloud in the appropriate thread, thanks (and no, I do not know the answer atm).

Thanks. Looking forward to it.

The nextcloud upload bug is a gateway bug so I thought this was an appropriate thread since there is no real changelog of the gateway release. My apologies.

this looks like a good place to ask

@kevink This release candidate of the gateway now properly supports the S3 ETag. If that was the reason for the upload issue with NextCloud, it is worth a try with this new gateway.

We have just moved the gateway to a new github repository. We are still working on our build script to automatically upload binaries when we tag a release. This is coming soon.

What OS platform do you use? I may try to build the binary manually for you to try.

I’m not sure it was Etag related but I’d gladly try it if it’s not too much trouble, otherwise I’ll just wait for you to finish the automated build scripts. The nextcloud upload issue is tracked in your jira (according to github) so it should be solved eventually.
I’m using ubuntu 18.04 x64

@kevink We have now the binaries included in v1.0.0-rc.4:


Thanks a lot! I try it immediately.