Log doesn´t work!

As I say in the title I am having problems with my logs. :sweat_smile:

Yesterday instead of using the powershell command I tried changing to a logfile on the system. Things didn’t go well at all, I even lost the node connection for about 10m for messing up the yaml file.

The point is that due to my inexperience with the power shell I don’t know how to redirect a route between that tangle of symbols (: \ /) so im not getting any logfile but in addictive now the command Get-Content "$ env: ProgramFiles / Storj / Storage Node / storagenode.log "-Tail 20 -Wait is not working either, the only data they give me is 24 hours old.

So at this point I am now, with no logs in file or powershell, nor do I dare to reset the service much and try combinations since yesterday it was a disaster and I receive constant errors “Error 1067: the process terminated unexpectedly”

So please, I’m here looking for guidance im afraid im stuck with this.

Thank you!

What did you do exactly?

1 Like

Follow the FAQs guide


1º Stop the node by power shell, Stop-Service storagenode. This showup:

Stop-Service : No se puede detener el servicio ‘Storj V3 Storage Node (storagenode)’ debido al error siguiente: No se
puede abrir el servicio storagenode en el equipo ‘.’.
En línea: 1 Carácter: 1

  • Stop-Service storagenode
  •   + CategoryInfo          : CloseError: (System.ServiceProcess.ServiceController:ServiceController) [Stop-Service],
      + FullyQualifiedErrorId : CouldNotStopService,Microsoft.PowerShell.Commands.StopServiceCommand

So I used the services windows for stop the node (error 1067 appears but anyway i guess the log went offline at that point.

2º Edit the log.output: winfile:///X:\Storagenode\node.log comand in order to introduce the path, but wasnt sure how paths in powershell works so probably i changed something not propperly.

3º Start-Service storagenode. But node didt wake up, after a few moments of despair it occurred to me to comment # the yaml line that I had edited. If I remember correctly, in powershell Start-Service storagenode doesnt work, but through windows services the node rebooted.

4º From that point my logs are gone from anywwhere.

5º Seeing that it had been a problem with the yaml file, I edited it again to try to leave it as before. I did not have a backup (I have learned the lesson on that) I left it so I suppose that here may be the error.

can be stdout, stderr, or a filename

log.output: winfile: /// X: \ Storagenode \ node.log

Show screenshot of config.yaml file with this line


1 Like

Here it is

To stop the service from the Powershell you should run the Powershell session as an administrator

Please, check the path (Powershell):

ls X:\Storagenode
1 Like

Im not completely sure, but as far as i know, i also tried elevated powershell (was yesterday and can´t remember every step). Probably didnt do it propperly, cause now elevated powershell seems to shutdown the node and reestar propperly.

ls X:\Storagenode shows this:

PS C:\Users\Servidor> ls X:\Storagenode
ls : No se encuentra la unidad. No existe ninguna unidad con el nombre ‘X’.
En línea: 1 Carácter: 1

  • ls X:\Storagenode
  •   + CategoryInfo          : ObjectNotFound: (X:String) [Get-ChildItem], DriveNotFoundException
      + FullyQualifiedErrorId : DriveNotFound,Microsoft.PowerShell.Commands.GetChildItemCommand

You do not have a path X:\Storagenode to store the log file node.log, please specify the correct path.

1 Like

I`ve tried. But never used the powershell before.

Should i create a text file named node.log or it will be created automatically?

the X in X:\Storagenode is part of some powershell function, or just a letter to change for my drive path.

if the path i want to use is

C:\Program Files\Storj\Storage Node

then this should be ok ??

log.output: winfile:///C:\Program Files\StorjStoragenode\node.log

Sorry for be so so newbie


log.output: winfile:///C:\Program Files\StorjStoragenode\node.log

Doesnt work. gives after save the Yaml file with notepad as admin with that path and try to reboot the node i get this

Start-Service : No pudo iniciarse el servicio ‘Storj V3 Storage Node (storagenode)’.
En línea: 1 Carácter: 1

  • Start-Service storagenode
  •   + CategoryInfo          : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
      + FullyQualifiedErrorId : StartServiceFailed,Microsoft.PowerShell.Commands.StartServiceCommand

The default value for it is:

log.output: winfile:///C:\Program Files\Storj\Storage Node\\storagenode.log
1 Like