Log Redirection Issue

I have a question… I’m attempting to redirect my logs to a file. When I follow the directions, modify the config.yaml file, and restart the server, the standard docker command to view the logs no longer works, as expected, but I’m not getting anything written to the file. I’ve tried both with and without quotes around the file name as shown below (without the # sign of course). I even tried creating the file with 666 permissions so everyone could write the file. No luck.

can be stdout, stderr, or a filename

log.output: stderr

log.output: /var/log/Storj.log

log.output: “/var/log/Storj.log”

Are there any location restrictions or file permission issues that I need to take into account?

Thanks for the assist!


Remember that you need to write to a path that is exposed through Docker. In my case, I’ve set the path to /app/config/node.log and then see it next to node database files.

ah… While I’ve run linux for a long time, I’m new to docker, so I did not realize it didn’t have access to the base machine drives. Thanks, I’ll see if I can redirect it to something inside the docker space.

Appreciate the help!

1 Like