Low overall success rates

Hey guys

I’m running the node via the docker container. My setup is a iMac, 1Gbps fiber internet, and a WD 6TB drive. I did a test on the drive the other day, and i was able to get 140MBps read/write.
However, running the acceptance script, i see that my upload success rate is 24.252%, download is at 55.801%
This is after 18hrs since last restart. storage2.max-concurrent-requests config is default.

========== AUDIT =============
Successful: 790
Recoverable failed: 1
Unrecoverable failed: 0
Success Rate Min: 99.874%
Success Rate Max: 100.000%
========== DOWNLOAD ==========
Successful: 2347
Failed: 1859
Success Rate: 55.801%
========== UPLOAD ============
Successful: 6472
Rejected: 0
Failed: 20214
Acceptance Rate: 100.000%
Success Rate: 24.252%
========== REPAIR DOWNLOAD ===
Successful: 0
Failed: 0
Success Rate: 0.000%
========== REPAIR UPLOAD =====
Successful: 0
Failed: 0
Success Rate: 0.000%

Is there anything i can do to improve these numbers? Anything i can debug?

Thanks

Assuming your iMac is not from the stone ages, your hardware is probably good enough. Most likely it’s your location and latency to the uploader that is limiting you. Not much you can do about that.

If it helps, there are SNO’s with much worse stats than you are seeing.

How is your HDD attached?

My iMac is a Retina 5K, 27-inch, Late 2015
I saw some worse stats too :slight_smile: But still, i want to improve, as my bandwidth and resources are mostly free.

My HDD is directly attached via USB to the iMac, not thru any USB devices. It’s using USB3.0. I’ve used BlackMagic disk speed test app to test the drive, and it showed about 150MB/s read/write.
Also, i made sure the drive is never going to be in sleep mode.

Should i try to increase max connections? What other params i could meddle with?

USB still adds latency to disk writes. Now with an iMac it’s probably your only option so not much you can do about that. Increasing the concurrency won’t help you here. Your stats show that no transfers were actually rejected so you haven’t run into that limit yet. And having more concurrent transfers would only lower your success rates. I don’t think there is much you can do about it other than move closer to the customer. :slight_smile:

I’m in San Diego, CA. NOT MOVING EVER :stuck_out_tongue: One of the best places that i’ve lived in.

Well, i guess, with time, things will get better, as more people will use the service. Maybe i’m failing hard on the EU people, where 100ms means a lot.

A lot of test data originates from Europe right now. But I’m guessing that will change when more customers are onboarded. Your time will come.

I am in the midwest US with a 400:20 connection and I have a ~35% upload success rate. I guarantee the cause is network latency to the uploader.

It’s an expected and desired property of the system, and it doesn’t indicate that anything is wrong with your configuration.

1 Like

I know nothing is wrong with my configuration
Was just trying to maximize my resources

I guess once it gets better usage from different geo locations, rates will be better

I guess once it gets better usage from different geo locations, rates will be better.

It will be