Migrating from BTRFS to USB 16TB ext4

I got my WD elements 16TB today and plugged it in the front USBport on my DS920+. I decided to move my node 2,92TB to the external USB-drive. I formatted it to EXT4 as recommended and the tried the “sudo rsync -aP /volume1/storj /volumeUSB1/storj”. After a short moment it says rsync not space left (28).

I got 16TB free, so how to overcome that problem?

Please double check your path, I think you’re missing a part called usbshare or something similar. I have 2 USB disks connected to my synology and this is where they are mounted.


To find the exact path, just go to the folder in DSM, right click and click properties. It’ll show the physical path there.

1 Like

Thx man… now it works. I must have written to someplace else when I was writing to /volumeUSB1/storj

Do you mount your usb-drive in FSTAB?

I just use DSM to mount them, but i believe Synology uses fstab in the background anyway.

You may have written the data to the system volume. I would check that and clean it up. Not a good idea to fill that to the brink probably. It’s pretty small to begin with.

Oops… I removed it using rm -rf in the correct directory /volumeUSB1/storj

Hopefully no harm done.

Mine just shows up as an USB Externaldrive. Is there anything more I should do?

I have another big question. Should I use my RP4, 4GB to run the client or should I just stick to Synology? I plan to use my RP4 to run homeassistant. I also have a UPS connected to the Synology.

Synology is probably a bit more powerful, but either should work. The UPS is a pro as well.