Moved house, new ISP using CGNAT

I’ve just moved house, took 2 weeks of my node being offline but now I’m in and have 1 gigabit up and download speeds. Tried connecting my node but all ports are closed when I check and they have just told me that they implement CGNAT so standard port forwarding won’t work. They’ve shared a link for how to use a reverse proxy for Plex but will this work for my node?

I’m not familiar with Plex. Any TCP reverse proxy should work.

I use the same raspberry pi to host my Plex server as well as the storj node. I’ll give it a go but it seems like quite a bit and could need manual work fairly often
How to access a Plex Server behind CGNAT with ngrok · - Passionate About Tech

Ngrok is fine and easy to set up.

The official servers are expensive though, you’ll lose money.

can’t you just order a static ipv4 address with your isp, then they will most likely bypass the CGNAT…

afaik, not super well versed in the various ISP procedures

So I’m giving it a go and opened a tunnel on ngrok, but where do I put the address in the run command? I tried to replace the:

-p 28967:28967/tcp  \

with the tunnel address


but I got

docker: Invalid ip address tcp:// address tcp:// too many colons in address
See 'docker run --help'.

Can anyone help get it running please?

In the meantime I have contacted my ISP and waiting for them to call back about opting out of CGNAT

Remove the tcp:// part.

Btw, it’s worth asking your ISP for a public IP. Make it clear that you don’t need a static IP, just a public one. Many node operators have been successful in getting their public IP back. Though this may be harder for new connections.

1 Like

You need to put the ngrok address at -e ADDRESS="

@Erikvv thank you that has allowed me to start the node again!

Just checked the dashboard and there is some data moving now but the QUIC is misconfigured, I guess as UDP isn’t forwarded, is this a big issue? It doesn’t look like ngok will allow it

Nope, not a big issue.

1 Like

Some ISPs who use CGNAT offer public IPv4 addresses for a fee. I pay £5 for the privilege.

What’s your ISP?

FWIIW, I too recently moved and set up a new ISP. I found that I had to port forward 443/80 to my device hosting the node to get the QUIC to work properly.

How did you do that? Not quite sure what you mean

It’s a new one to the area, Lightspeed. Really fast but I did speak to an engineer and he was very apologetic and understood that they can’t give a separate public IP yet but hopefully in the next 6 months or so that might be an option