Moving node from windows server to unraid docker

I’m currently copying my data from a windows server i had running the windows node to a new unraid server i just set up. On this i’m going to set up the docker node. If i move over the identity files and set the data location, can i just move this over, or is there anything in the config specific to windows/linux?

Have a look at above links.

Hmm, thats a bummer. I’ll have some rethinking to do. Thanks.

1 Like

As an update, after reading a bit more, the bug should have been fixed in the current version of unraid. So i decided to go ahead with the move, i just copied everything to the unraid share and started the docker container without any problems. I have set the docker container to not auto start so that i can be sure that the volumes are up before i start storj. I’ll see if in the future the mentioned problems do turn up, if i do, i’ll update this topic.


@evilburt I know this is a really old thread, but was curious how this worked out for you?

Can’t speak for evilburt, but I migrated 2 nodes from windows to Unraid as well, and I am not experiencing any of the described problems

1 Like

within the last few months I went ahead and built my first unraid server to start utilizing misc old drives…most recently adding in two 12TB WD Reds that I just replaced in my synology with 18TB Exos. My unraid server now has 7 array drives, totaling 74TB.

so have been messing around with various ideas, and about a month ago went ahead and set up a testnet storj node on docker in the unraid server. although, more recently was thinking about migrating one of my mainnet nodes to it as well, which is currently running on a raspi-4 (4GB) with an external, usb 1TB HDD.

So I’m curious, how did you set up your node(s) in unraid? I assume you created different shares for all of your storj data? do you have the storj share(s) being populated across different array drives, or did you just set them to be dedicated share-drives? I assume you have those shares not using cache (if you have that setup)?

I set up all of my non-storj shares to exclude a 4TB HDD in the array, and then have the storj share only including that 4TB HDD. I have two different cache pools setup in Unraid, but I have the storj share not using either of those. This seemed like the easiest way to keep information/disk usage separated within the server.

I would just use the unassigned devices plugin to mount your hard disk and use that for storj. That is how I do it

1 Like

I did not have any problems concerning the stability or the described problems, so in my case it worked perfectly. However what you should pay attention to, something i did not, is that the parity disk cannot be a smr drive, my parity drive was a smr drive and wasnt really a problem for my day to day use before i installed storj, but storj does a lot more writes and this completely took my system to its knees untill i replaced my parity drive with a cmr disk. The data disks seem to have less of a problem with being smr drives.

1 Like

so what it sounds like is you did set your unraid server up to use a share for the data storage location for storj node, versus with pietjebell suggested/mentioned above with using unassigned devices plugin to mount a disk?

Indeed, i made a share for the data storage location because i wanted disk redundancy

I am also using single disks with unassigned devices. Works fine so far and the filewalker is pretty fast :slight_smile: