Multinode Setup help

Ok So i’m Fairly new to computers and am trying to figure this out so forgive my Ignorance.

I have 1 Node up and running so I am trying to set up another node.

I downloaded the multimode dashbored From here.

I ran the following command seamed to go mostly fine.
but I have an Unsigned identity. and I cant run the setup command.

C:\Windows\system32>identity create multinode --difficulty 1
2023/11/03 21:56:25 proto: duplicate proto type registered: node.SigningRequest
2023/11/03 21:56:25 proto: duplicate proto type registered: node.SigningResponse
2023-11-03T21:56:25-06:00 INFO Anonymized tracing enabled
Generating key with a minimum a difficulty of 1…
Generated 4 keys; best difficulty so far: 9
Found a key with difficulty 9!
Generated 4 keys; best difficulty so far: 8
Found a key with difficulty 8!
Generated 4 keys; best difficulty so far: 8
Found a key with difficulty 8!

Found a key with difficulty 8!
Unsigned identity. is located in “C:\Users\compt\AppData\Roaming\Storj\Identity\multinode”
Please move CA key to secure storage - it is only needed for identity management and isn’t needed to run a storage node!

this is what I get when I try to run the rest of the command.

C:\Windows\system32>C:\Windows\system32>multinode setup
‘C:\Windows\system32’ is not recognized as an internal or external command,
operable program or batch file.

For the multinode dashboard it doesn’t matter, it just need an identity to run properly (because it reuses some Storj common packages), but since it’s not contacting satellites, its identity may be unsigned.

this is because you need:

  1. use a casual user, not admin to run the Command Prompt
  2. if the binary is not in the current folder, you need to provide a full path to it, i.e.
c:\Users\User\Downloads\multinode.exe setup

Use the path where you extracted the binary.

I usually use PowerShell to download and extract the latest multinode binary:

Invoke-WebRequest -o; Expand-Archive . -force

then the setup command would be (it should be executed only once in the first time):

./multinode setup

and run:

./multinode run

ok thanks so much this worded for me. I have the Multimode Dash bored working.
now i’ll try working on moving the nodes over.

on the multinode dashboard Node ID are they asking for Identity Key? or an ID for me to recognize the node?

*API key I am Having hard time generating on command Promt
nor sure how far off base I am here but this is the command I am running.

C:\Users\compt>C:\Program Files\Storj\Storage Node\storagenode.exe issue-apikey --log.output stdout --config-dir C:\Program Files\Storj\Storage Node\ … --identity-dir C:\Users\compt\AppData\Roaming\Storj\Identity …
‘C:\Program’ is not recognized as an internal or external command,
operable program or batch file.

NodeID you can copy from your dashboard.

I did not get what do you want to move. The multinode dashboard is just a dashboard, it will show Stat for the registered nodes, nothing else.

You should execute the command without “…” and should quote paths with spaces, i.e.

"C:\Program Files\Storj\Storage Node\storagenode.exe" issue-apikey --log.output stdout --config-dir "C:\Program Files\Storj\Storage Node\" --identity-dir "C:\Users\compt\AppData\Roaming\Storj\Identity\storagenode"

Running this Command I get

C:\Users\compt>“C:\Program Files\Storj\Storage Node\storagenode.exe” issue-apikey --log.output stdout --config-dir “C:\Program Files\Storj\Storage Node" --identity-dir “C:\Users\compt\AppData\Roaming\Storj\Identity\storagenode”
2023/11/05 13:57:58 failed to check for file existence: CreateFile C:\Program Files\Storj\Storage Node” --identity-dir C:\Users\compt\AppData\Roaming\Storj\Identity\storagenode\config.yaml: The filename, directory name, or volume label syntax is incorrect.

I double Checked the File locations they should be good Except I’m Not to sure about the Storagenode.exe file? when I go to that location I don’t see a file with .exe anywhere.

Please try this command:

"C:\Program Files\Storj\Storage Node\storagenode.exe" issue-apikey --log.output stdout --config-dir "C:\Program Files\Storj\Storage Node\\" --identity-dir "C:\Users\compt\AppData\Roaming\Storj\Identity\storagenode"

Please note a double \\ in the path to the config.yaml file.

1 Like

thank you got everything up and running

1 Like

Hi, according with the information at main branch seems that identity isn’t needed anymore, at least to run multinode on docker but I can’t run it correctly, the log says always looking for the identity.cert file

docker run -d --restart unless-stopped \
    --user $(id -u):$(id -g) \
    -p \
    --mount type=bind,source="<multinode-config-dir>",destination=/app/config \
    --name multinode storjlabs/multinode:latest

This is the log output

2023-12-04T23:14:13Z    INFO    process/exec_conf.go:318        Configuration loaded    {"Location": "/app/config/config.yaml"}
2023-12-04T23:14:13Z    DEBUG   process/tracing.go:104  Could not read identity for tracing setup       {"error": "open ./identity.cert: no such file or directory"}
2023-12-04T23:14:13Z    INFO    process/tracing.go:73   Anonymized tracing enabled
2023-12-04T23:14:13Z    DEBUG   tracing collector       monkit-jaeger@v0.0.0-20230707083646-f15e6e8b7e8c/thrift.go:149  started
2023-12-04T23:14:13Z    DEBUG   db      multinodedb/database.go:72      Connected to:   {"db source": "file:config/master.db?_journal=WAL&_busy_timeout=10000"}
2023-12-04T23:14:13Z    INFO    db      migrate/versions.go:218 Database Version        {"version": 0}
2023-12-04T23:14:13Z    DEBUG   servers lifecycle/group.go:100  started {"items": ["console:endpoint"]}

I look for more information at main.go file and find this

	_ = rootCmd.PersistentFlags().MarkDeprecated("identity-dir", "multinode no longer requires an identity key")

No longer needed an identity key but … without it you cannot launch the dashboard