My having issue in setting up ffi?

my ffi is giving this error

FFI API is restricted by “ffi.enable” configuration directive

Hello @mtechub-pvt-ltd,
Welcome to the forum!

This is a php option. What are you trying to build to use Storj?

If you check your php.ini file you will find this line by default:

;ffi.enable=preload

You need to change it to:

ffi.enable=true

More detailed instructions depend on the operating system and installation method.

Hi i tried to do that. here is some info and what i have done

allright my setup

lenovo thinkcenter 7 gen
16 gb ram
60 gb nvme
1.6tb ssd
proxmox 7.3

nextcloudpi

problem:
trying to use storj as a external storage getting error:
“ffi api is restricted by “ffi.enable” configuration directive”

what i have done

in /etc/php/8.1/cli/php.ini

i have ffi enable and set to true
reaload apache and reboot lxc

nothing change stil same error

do anyone have an idea how to fix?

Kind regards

You need to change it in the lxc container, not on your host unless you run Nextcloud directly on your host, not in lxc container.

hi and thank you for your reply :slight_smile:

my change is in the lxc container.

Can it be it is in a lxc container i have this error?

Perhaps it is missing this module and you need to install it separately, see Storj - Apps - App Store - Nextcloud

have i have tried to install the libffi still the same error im not using docker.

It should be installed inside the LXC container. Please note - all changes inside the container will disappear when you re-create it.
You have several options:

  1. Every time when container is re-created you need to Install the library and make sure that the module for ffi is installed inside the container (the file /usr/local/etc/php/conf.d/docker-php-ext-ffi.ini inside the container is exist), then make changes in php.ini
  2. Or prepare the container once and make a lxc/lxd image and use it to run the container.
  3. Or use the prepared docker image (it requires docker daemon though)
  4. Or use VM for Nextcloud with needed changes
  5. Or install it directly on your host

yes i got the solution now

when you have php 8.1

you need to change ffi two places

in
cli/php.ini
and
fpm/php.ini

i fund that is the case becuse i had nextcloud issue php memory limit
and there i had to change the vaule both places

1 Like

now im trying to copy from the storj folder in the nextcloud and all my storj folders says pending.

have have 110gb worth of data do it just takes time or is somthing wrong?

kind regards

What is your up- and downstream bandwidth limit (speed) on this server?
And to where you copy your data from the Storj DCS bucket?