Need assistance with comming back online asap

Hi guys,
Got a problem, want to bring the node online asap.

Got a node on a 16TB HDD. Connected to a PC with USB docking station. It was working surprisingly well. No problem with USB whatsoever on my AMD A320M-A motherboard PC.
(Was still on usb, because i was expanding from 1TB disk to 16TB, months ago)

So now, i clicked to safely unmount it, icon on windows bar, and i took the disk from the docking station.

I bought myself a new LSI SAS3081E-S SAS controller,
with another PC i connected it, and it works.
Wanted to check, if it sees HDDs as big as 16TB.
Added this freshly unmounted HDD.
And windows starting, it is win7, clean with manually installed updates SP1 and such, almost all updates installed. Its a spare PC, excellent for service and diagnostics.

So windows is staring, and it want to check the new HDD for errors i let it.
It was working like 36-40+ hours and fixing many errors in indexes.

I guess i should turn off the dock station, and not just take out a HDD when dock station was still On, and attached to PC.

The problem is the chkdsk seems to stop after 2 from 3 part. and don’t go any further. Computer is freezed. i can only restart it.

I ran it 2-3 more times to full scan, and it supposedly found some few more errors like showed above, so at last full run, it founds none, and just checks and stops at:

I have a HIREN’s 15.2 bootable usb stick, so was trying to repair it with it
BUT TestDisk says it cant help me, says MFT is wrong or faild.
And can’t even see files under “|List|” and can’t rebuild MBR, because it says its ok.
And HDAT2 another program on a hiren’s stick, sees something with MBR, but no option to fix it.

Also HDAT2 scanned all disk for bad sectors and all is green OK.
Just the disk files are not recognizable under windows, when i skip the chdsk scanning.

Sooo i would like to ask some experience, what do You advice me, what to do to bring the disk to usability asap? I tried many tools more on that hirens 15.2 but none seems to fix it aaah.

In short, it’s just 1TB node. Start over with a new node on the new HDD, and forget about this one. It’s fried. Even if you manage to repair the data etc, your blobs will never have all the needed pieces, and after a while can fail audits and you get disqualified. The chkdsk can recover the pieces, but dosen’t know where to put them and creates files like found0001, found0002 etc, if I remember corectly. You don’t know where to put them either. So they are lost.
Second, take some precautions not to repeat this: if you are using any form of external mount, stop the drive from windows, then stop the power to the external mount, then disconnect the drive; if you don’t have UPS or Toshiba MG drives with persistent cache, disable writecache on that drive. Regularly check for new firmware for your drive and also check for compatibility with older OSes.

That is your first error.

For how long?

To check your new RAID card, you connected a STORJ data HDD?

I don’t know if win7 supports 16TB or GUID and I can’t be bothered to google that fact; That OS support has ended 3y ago.

Windows 7 wants to check a HDD? Ohh boy.

I mean, at least you (hopefully) learned something.

i mean i checked old HDD first with that SAS controller, and it worked, so i decided to check the 16TB. YEah win7 sees 16TB’s, just SAS controllers not sure. YEah docking station for USB was working just fine all the time. I was really happy, it was just like on sata3. Yeah i learned, not to take a HDD from the device still connected to power.
Yea snorkel, it was 3TB or 4TB today, it gained from those months ;(
I don’t belive chkdsk misplace files, i did some chkdsk’s after power off sometimes, and it was just necessary, did not misplaced my files even if found errors.
(I hope, the audit scores all still 100% on every node)
Yea MFT is fked. need to rebuild that MFT. Gosh.
Anyone know some modern tool to rebuild that beside testDisk program?
2. im thinking about yet: cloning the 14,5TB partition, on that 16TB HDD, mayby to a STORJ mounted disk? because i don’t have another 16TB disk. So mayby to use some partition tool for cloning? and format my original disk, and just download the copy back? make sense?
edit: oh no, what i am talking about, even if MFT problem would not be cloned with it,
it’s 14,5TB x $4 for Storage and then $7 for downlaod, maaaan…$58 + $101,5,
i have awhole another 16TB HDD for $209 lol,
if anyone wonder why people don’t waanto use the cloud…
and thats a 1 time action, try to pay $7 every download of this…

okay wait guys, wait wait wait,
i opened with Windows installation DVD,
i did “diskpart”, and it shows RAW, and should be NTFS,

any ideas what commands to use now?

those internet tutorials are misleading and not detailed,
i see some propositions like, but i dont wanto to f’up anuthing on blind,

bootrec /rebuildbcd
bootrec /fixboot
bootrec /fixmbr

how to incorporate this propositions specifically for the situation,
to act on the exact disk “D” or “volume 4” here?

some say You can’t choose a drive with bootrec,
And have to use, “bootsect” instead,
bot got no idea how yet, i’m not proficient in this,
never did that before

can’t just go to d: because its damaged or unreachable it says

I’m not verry familiar with HDD recovery tools, I never needed them. I remember Norton tools was a thing many centuries ago. Maybe Partition magic if it’s still around.
But, as an alternative, you can try a files recovery tools, like Recuva, if you can’t repair the MFT. Maybe someone more expirienced can guide you step by step with what’s the best course of action.

seems pretty old. how was that drive even formated? fat32? ntfs?

Orginally NTFS, with GPT.

EaseUS shows that first hiden partition is unallocated, 129MB, there should be infos about the access to whole disk, and that’s not there at the moment i guess… thinking how to fix this, and keep the 3,17TB of data on the main allocation…

What I would do is to go for GParted and its auto tools because it looks like a partition problem. As far as I remember, you can find it preinstalled with:

Hiren’s BootCD PE
KNOPPIX KNOPPIX - Live Linux Filesystem On CD
and here GParted -- Live CD/USB/PXE/HD

I would recommend the first one. If it is not resolved by GParted it might be a more serious problem. Then I would briefly try TestDisk Partition Recovery and File Undelete (again, as far as I remember, it is also included in above mentioned distributions). And I said briefly for a reason. Because, over the years, I found out that even if spending a few days with all the more advanced tools, in case of serious problems it is really hard to recover data. You really need to know what you are doing and there is not much resources on this topic in the net. So now, I go for GParted. If not successful I save myself time. Good luck.

1 Like

is this node utterly F’d?

Edit: i got same disk model working in another node,
will it’s copy of that 129MB first hiden partition will do anygood?
as a doner, that would be a MFT of whole another node and its files tho… but as a doner of same type MFT for that unallocated first partition, maybe to do something with it?..

I dont think its completely done yet, but please dont make any changes to the geometry of the disk by any means. Looks like the problem with the first sector but its only a guess. Can you do some additional tries with testdisk, document every single move you were doing from the very beginning without any exception and possibly send it by OrlenPaczka to the specialist? :- )

Is this controller in IT mode? You might need to flash the IT firmware to use the ports independently.

Yes, it is, but i took the HDD from it rather fast, and now fighting to bring it to life directly on motherboard from few days.

Cześć, and how is it going, are you making any progress?

1 Like

No, i will buy some software at discount promo code 50% at monday when its starts


and try, despite ppl says its snake’s oil company,
im trying its freeware now, and seems cool and i tried a few before,
$20 for a deal seems fair, never know when it can help You.
And will test hows that partition rescue tools works.

TestDisk and GParted are the best tools available on the market.

With you get both of them in one iso. Plus you get Ntfs-3g so you should not get the error you got in your picture.

IMHO: Not worth bothering looking into other software.

It’s just 1TB of data… You’ll get it back in 1-2 months.

1 Like

its ~ 3TB already, and it’s 3 years old node, hate vetting and 15 months period…

TestDisk wasnt able to do anything, i probbaly nuled the data from this hiden system partition with TestDisk, when i pressed |write| at some point, now i gotto try to recover it

Edit: + im not sure there might be some private backups on this HDD as well, on 500GB part of this 14,55 partition, soo i would like to take a look what fiels are there.
GParted, thx for that insides, will try this with the NTFS 3g packet again maybe.

yea the cause was to take HDD from the usb docking station, while it was still powered On (despite correct safe removal from windows)

1 Like

The good point is that even as raw, the partition is still visible. I understand raw in a way that the file system is no longer recognized by the operating system. I guess you tried chkdsk X: /f where "X" is the drive letter of the RAW partition and the "/f" flag tells chkdsk to fix errors.

If not getting any advice here, I would probably focus to preserve the hdd abandoning data recovery part (its just a node, not the memories nor documents) especially if the reason was related to power failure. I stick to my initial advice about GParted, TestDisk briefly and time.

Would you have any suggestions related to the workflow in the context of described situation?

To be honest, I don’t understand the situation. It is all very convoluted to me.
Data recovery needs a clean, levelheaded, exact way of working. This does not seem to be the case here. He does not understand how it happened, he tried multiple tools, he did not read errors… In summery, the information we have is sparse and not of good quality. Any advice is just wild speculation.

In a normal situation, I would first DD to another drive and work with that. Then I would try to recover the MBR. If that really does not help, you could restore normal files with Testdisk to another disk. Not sure about STORJ files. But probably not worth it for 3TB anyway, takes a very long time. And if he did not understand why that happened, and/or where he acted against best practices, it won’t be the last node to go belly up.

Only advice I can give: Don’t use Windows. Don’t use Windows that is EoL. Don’t use Windows that was made for 2TB GPT partitions with a 14TB drive. Don’t use USB for drives, don’t use USB hubs for drives.
Ignore best practices, but don’t be surprised when something goes sideways.