NEED HELP QUICK! Reboot did not restart my docker container

I did a restart due to a firmware upgrade.
I was told on the forum restarts would be fine, okay.
But now my docker is not running anything.

What it shows:

docker ps -a
1 Like

Oh it’s still there.
I’m still not used to docker.

What it shows:

docker ps -a
1 Like

lol, I’m slow today.

CONTAINER ID   IMAGE          COMMAND         CREATED       STATUS                      PORTS     NAMES
cebcb1ae3ef8   d8ef6da404c1   "/entrypoint"   6 weeks ago   Exited (0) 28 minutes ago             storagenode

How do I restart this thing?

docker stop -t 300 storagenode
docker rm storagenode
1 Like

Nononononono, I’m not going to remove it.

# docker start storagenode
Error response from daemon: invalid mount config for type "bind": bind source path does not exist: /root/.local/share/storj/identity/storagenode
Error: failed to start containers: storagenode

OK, don’t panic :wink:

docker restart -t 300 storagenode
1 Like
 # docker restart -t 300 storagenode
Error response from daemon: Cannot restart container storagenode: 
OCI runtime create failed: container_linux.go:367: 
starting container process caused: process_linux.go:495: 
container init caused: rootfs_linux.go:60: 
mounting "/root/.local/share/storj/identity/storagenode" 
to rootfs at "/app/identity" caused: 
stat /root/.local/share/storj/identity/storagenode: 
no such file or directory: unknown
ls -la /root/.local/share/storj/identity/storagenode
1 Like

It’s not there. It’s at some other place. Let me refind it.

history | grep "docker run -d --restart unless-stopped --stop"
1 Like
    6  docker run -d --restart unless-stopped --stop-timeout 300     
-p 28967:28967     -p 14002:14002     -e WALLET=""     -e EMAIL=""     -e ADDRESS=""     -e STORAGE="2TB"     --mount type=bind,source="/home/folaht/Stohrje/identity",destination=/app/identity     --mount type=bind,source="/Volume/storagenode",destination=/app/config

Wait, that’s what I tried a few minutes ago and didn’t run.
There’s no previous of that.

# ls -lah /share/CACHEDEV1_DATA/Public/storagenode
total 32K
drwxrwxrwx 2 admin administrators 4.0K 2021-03-16 13:49 ./
drwxrwxrwx 8 admin administrators 4.0K 2021-05-02 07:37 ../
-rw-rw-rw- 1 admin administrators  562 2021-03-16 09:40 ca.1615884001.cert
-rw-rw-rw- 1 admin administrators 1.1K 2021-03-16 09:40 ca.cert
-rw-rw-rw- 1 admin administrators  241 2021-03-16 09:36 ca.key
-rw-rw-rw- 1 admin administrators 1.1K 2021-03-16 09:40 identity.1615884001.cert
-rw-rw-rw- 1 admin administrators 1.6K 2021-03-16 09:40 identity.cert
-rw-rw-rw- 1 admin administrators  241 2021-03-16 09:40 identity.key

Run the command line 6 again:

1 Like

Can’t do. That’s not the old command I used to run the storage node.

--mount type=bind,source="/share/CACHEDEV1_DATA/Public/storagenode",destination=/app/identity
1 Like

I think it has restarted again.

It’s back!!! :star_struck:
:rofl: :joy: :sweat_smile: :smiley:
:hugs: :hugs:
:+1: :+1: :+1: :+1:

What I did:

# mkdir -p /root/.local/share/storj/identity
# cp -rf /share/CACHEDEV1_DATA/Public/storagenode /root/.local/share/storj/identity
# docker restart -t 300 storagenode

This is like QNAP ?

Check it works :slight_smile:

Save this “docker run …” command to a .txt file for future reference

1 Like

Looks like I lost all my download and traffic history, but the all the storage and payout information is still there.

Yeah thanks.
I think what happened is is that last time I could not figure out where to put my identity files, so it was all over the place.
I had it stored in twenty locations and once I had it running I started deleting all the folders where I was sure Storj was not getting them from.

I guess I was wrong.


Are you sure the data is here? or a different path?

1 Like