Need help starting 2nd node on same machine

Hi,

I am using a Raspberry Pi 4 with 8gb ram, debian OS. Second node identity was accepted.

On my local network, I can see 192.xx.xx.xx:14002 and node 1is good, but 192.xx.xx.xx:14003 and the page says node 2 is offline.

When I do docker ps -a it shows that it is running but the dashboard shows OFFLINE.

What can be the problem? Here is my configs, first node one and then node two that are one the same machine.

and the first node config is:

First node

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28967:28967 \
    -p 14002:14002 \
    -e WALLET="?????" \
    -e EMAIL="??????" \
    -e ADDRESS="???????" \
    -e STORAGE="1800GB" \
    --mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode-penknife",destination=/app/identity \
    --mount type=bind,source="/mnt/penknife",destination=/app/config \
    --name storagenode-penknife storjlabs/storagenode:latest

Second node

docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28968:28967 \
    -p 14003:14002 \
    -e WALLET="???????" \
    -e EMAIL="???????" \
    -e ADDRESS="???????" \
    -e STORAGE="1800GB" \
    --mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode-eneloop",destination=/app/identity-eneloop \
    --mount type=bind,source="/mnt/eneloop",destination=/app/config-eneloop \
    --name storagenode-eneloop storjlabs/storagenode:latest

When I run

docker logs --tail 100 storagenode-eneloop

I get

2020-07-28T20:47:37.686Z        INFO    Configuration loaded    {"Location": "/app/config/config.yaml"}
2020-07-28T20:47:37.691Z        INFO    Operator email  {"Address": "?????????"}
2020-07-28T20:47:37.691Z        INFO    Operator wallet {"Address": "?????????"}
2020-07-28T20:47:38.496Z        INFO    Telemetry enabled
2020-07-28T20:47:38.515Z        INFO    db.migration    Database Version        {"version": 42}
2020-07-28T20:47:39.107Z        INFO    preflight:localtime     start checking local system clock with trusted satellites' system clock.
2020-07-28T20:47:44.973Z        INFO    preflight:localtime     local system clock is in sync with trusted satellites' system clock.
2020-07-28T20:47:44.974Z        INFO    bandwidth       Performing bandwidth usage rollups
2020-07-28T20:47:44.974Z        INFO    trust   Scheduling next refresh {"after": "5h6m45.450694457s"}
2020-07-28T20:47:44.975Z        INFO    Node ??????????? started
2020-07-28T20:47:44.975Z        INFO    Public server started on [::]:28967
2020-07-28T20:47:44.975Z        INFO    Private server started on 127.0.0.1:7778

did you forwared 28968 to node ip also?

1 Like

I have forwarded the port from the router, just like I did for the first node.

Both nodes are using the same DDNS name, is that a problem? Do they need to be different?

ddns can be same, how is your forward looks like?

1 Like

Should be

-e ADDRESS="???????:28968" \
1 Like

Port forwarding details here

cf86f285-ab2c-4f87-ad1a-a3b1bfbcc0d0

My config for node 2 usese this -e ADDRESS=“DDNS:28968” \

okay, ports really open, I used my VPS to check my home port connection.

articulateape@server:~$ nc -vz MY-IP 28967
Connection to MY-IP 28967 port [tcp/*] succeeded!
articulateape@server:~$ nc -vz MY IP 28968
Connection to MY-IP 28968 port [tcp/*] succeeded!

Then please, check your second identity:
https://documentation.storj.io/dependencies/identity#confirm-the-identity

1 Like

I checked the identity and the numbers are 1 and 2, I need to do it again.

I made the identity with Win Powershell, does the command need to match the node name like this?

./identity.exe create storagenode-eneloop

Not necessarily, but it’s much convenient to use the same name. The main point - it should be different from the current one, if you create it on the same machine and did not move the previous.

The name in the identity create NAME is a name for the folder. For Windows it would be %APPDATA%\Storj\Identity\NAME

1 Like

The node is working now, what a great feeling!

The CLI shows shows it is online, and the dashboard is also working. No ingress or egress but I think that will come later.

Thank you @Alexey and @Vadim for your help

edit: I have ingress now, feels great!

2 Likes