Need help to open port 28967

Hi, I’m setting up my first node and can’t open the 28967 port no matter what I do! I tried to configure my router but it’s not working! Win10 is properly configured to allow connections through Firewall.

My router is Huawei EG 8145 v5, Win10 21H1:

Hi @ZeroCool1974-BR
Do you have a public IP address listed in the router? The rule looks correct.

Please show Windows Firewall rules for 28967 to be unblocked, or the Windows firewall showing as disabled.

I tried disabling Win10 Firewall but it didn’t work either!

Port trigger should not be used.

The correct page is IPv4 Port Mapping to allow the port forwarding. Please include 28967 in the External port number boxes as well.

You can use this to test your public IP in the router - What is My IP Address?
You can use this to test 28967 is open - Open Port Check Tool - Test Port Forwarding on Your Router

Disabled Port Trigger and changed the config of Port Mapping but didn’t work…

I’m suing BTFS and BTFS 2.0 running at the same time each at different ports 4001 and 5002 and they are automatically open using UPnP function of the router, why can’t Storj work like that?

Tried disabling Windows Firewall and UPnP on router, nothing changed. I will try tomorrow on a fresh installed Win10 as a last resort!

Nah, this would be overkill.

Hello @ZeroCool1974-BR ,
Welcome to the forum!

Please, compare the WAN IP with IP there: Open Port Check Tool - Test Port Forwarding on Your Router
If they do not match - you doesn’t have a public IP. In this case port forwarding will not work. You would have these options:

  • call to your ISP and ask for public IP, it could be dynamic but must be a public (the WAN IP will match IP on yougetsignal). You can say to the call support person that you need to have an access to your security IP-cam from anywhere to do not explain Storj;
  • switch to ISP who offer a public IP;
  • use VPN services with port forwarding feature such as, ngrok, PIA, AirVPN, PureVPN, etc.

If your WAN IP matches IP on yougetsignal, you need to add an inbound rules to your firewall for 28967/tcp and 28967/udp, please do not disable a Windows firewall - it will be enabled back automatically sooner or later, so it’s better to configure it. The storagenode software for Windows expecting the Windows firewall up and running, it can even misbehave if it’s disabled.

I also had problems when tried to open ports the traditional way.
Bcs of this i have cron runing on every 15 minutes to open or keep open the needed ports.
I doing this on linux, but im sure you are able to do cron jobs on windows too.
Im using this python code to add upnp forwards

The commands look like this:

python2 -e 28967 -v -t 0 -r -p TCP -l 28967 -d ‘storjtcp’
python2 -e 28967 -v -t 0 -r -p UDP -l 28967 -d ‘storjudp’
python2 -e 28968 -v -t 0 -r -p TCP -l 28968 -d ‘storj1tcp’
python2 -e 28968 -v -t 0 -r -p UDP -l 28968 -d ‘storj1udp’
OFC you need to figure out your parameters on your side, and evetually to use python3 version of command

Please, do not use UPnP - it’s not secure

1 Like

Thanks, I will try calling support of ISP, I really do have some surveillance cameras, my house was invaded 6 months ago, they left with more than 10 thousand dollars of electronic equipment. Here in Brazil it’s a lot of money for our standards.

That’s terrible @ZeroCool1974-BR So sorry to hear that happened.
It’s a whole lot anywhere by any standards. Cameras make sense.

Hi @ZeroCool1974-BR .
That is terrible information :frowning: . I want to help you. Please, look on my screenshot. I have newer version of same router, like you have and this is working setup for me.

I think, that “External port number” must be set too.

Please check / share / anonymite your “docker run …” command. With QUIC failed notification I spot, that I missing “-p 28967:28967/udp” for Docker.

As @Alexey mention, you must have public IP address (static is preferable, but dynamic is enough too - I have dynamic; this router can handle NoIP service, no additional software installed).

I suggest:

  • temporary turn off Windows firewall (if node start working, you must tune Windows firewall rule)
  • double check router setup (see my screenshot)
  • double check “docker run …” command
  • double check public IP availability (you can temporary expose RDC service and use different connection with different device, e.g. after setup this, try to access your computer remotely)

and PLEASE - after tunning dont forget clean up your settings to be secure!!!

I glad to help you, but please consider, that I not use Windows. I have in all my “home world” only Linux. If you have additional question, dont hesitate to ask :wink: .


Sorry to hear about invaders! Then you definitely need to have an access to your cams!

1 Like