Need help with node, it is offline

Hello, so all of sudden my node went offline, everything was running fine and all of sudden it went offline, I checked my connection and everything looks fine. Thank you in advance for your help. I tried posting a log here but it wouldn’t let me.

Hi @shadow1337,

Without the log there’s very little we can do. Please try to post only the WARN, ERROR or FATAL log entries.

Here are screenshots of the log since it won’t let me paste it here.

https://www.yougetsignal.com/tools/open-ports/

closed

closed2

Look:
https://forum.storj.io/search?q=Dynamic%20DNS%20

As @peem has written/checked your node is not accessible from the internet so you should double check all firewall and port forward settings.

often this is ddns having a wrong ip address because your wan/internet ip address changed.
while your ddns software or such didn’t register and update the new ip to the ddns service… for whatever reason.

In the Windows command line (CMD):

nslookup myip.opendns.com resolver1.opendns.com

compare the result with:

ping node1337.sytes.net

Both results should have the same external IP address. If this is not the case, the Dynamic DNS service has not updated the current IP address. You need to set it (preferably in the router), and how … search on the websites of your Dynamic DNS provider (sites.net)

1 Like

Thank you everyone. I got it fixed!

Hello @shadow1337 ,
Would you mind to share what was a mistake to help future readers?

1 Like

Looks like for some reason my IP changed so I had to set up my port forwarding again. The IP that changed is the one that displays under “IPv4 Address” when I do a “ipconfig”. I made sure that the port forwarding settings matched with the new IP. Hopefully I explained this well enough, I am learning as I go. Let me know if I can provide a bit more information to make it more clear.

I think you need to Setup Dynamic DNS Service

i think you dont need to provide the current public IP address (just leave the field blank) when setting up your port forward, just the port and the local IP address and port of your node.

also, you must update the external address of your node if you’ve used public IP address before, you must use now the hostname (the one from “Setup Dynamic DNS Service”)

You need to configure a static local IP either on your router (DHCP section) (recommended) or on your PC (not recommended), then the local IP would not change after reboot.

@clearing They mean the local IP in the port forwarding rule, not the public one.

1 Like